summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-12 14:24:06 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:59 -0400
commit2f12a4609035f23a717d665fdcee16a3c4de651f (patch)
tree31ba910136e0523774d7cb07dda8cf04d148e6a0 /gnu/packages/gnome-xyz.scm
parenteda94d13d4b1845c398ceee34c6bff7364bceaa6 (diff)
gnu: gpaste: Update to 42.1.
* gnu/packages/gnome-xyz.scm (gpaste): Update to 42.1. [meson]: Delete argument. [phases]{fix-introspection-install-dir}: Use #$output. [native-inputs]: Remove autoconf, automake and libtool. [inputs]: Remove graphene. Add gtk and libadwaita. Sort. * gnu/packages/patches/gpaste-fix-paths.patch: Update patch.
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm31
1 files changed, 18 insertions, 13 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 48b162d09a..74eaf74a37 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -776,7 +776,7 @@ notebooks and tiling window managers.")
(define-public gpaste
(package
(name "gpaste")
- (version "3.42.2")
+ (version "42.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -785,19 +785,25 @@ notebooks and tiling window managers.")
(file-name (git-file-name name version))
(sha256
(base32
- "1k5qvgzwl357k72qfim5zfas2a0n6j24jnlm1v472l7h6gb6lssm"))
+ "1dlqa69zvzzdxyh21qfrx2nhpfy0fbihxpgkxqmramcgv3h5k4q3"))
(patches
(search-patches "gpaste-fix-paths.patch"))))
(build-system meson-build-system)
(native-inputs
- (list autoconf automake gettext-minimal gobject-introspection
+ (list gettext-minimal
+ gobject-introspection
(list glib "bin") ; for glib-compile-resources
- libtool pkg-config vala))
+ pkg-config
+ vala))
(inputs
- (list appstream-glib libarchive gjs mutter graphene))
+ (list appstream-glib
+ gjs
+ gtk
+ mutter
+ libadwaita
+ libarchive))
(arguments
- (list #:meson meson-0.59 ;positional arguments error with meson 0.60
- #:glib-or-gtk? #true
+ (list #:glib-or-gtk? #true
#:configure-flags
#~(list
(string-append "-Dcontrol-center-keybindings-dir="
@@ -809,12 +815,11 @@ notebooks and tiling window managers.")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'fix-introspection-install-dir
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* '("src/gnome-shell/extension.js"
- "src/gnome-shell/prefs.js")
- (("@typelibPath@")
- (string-append out "/lib/girepository-1.0/")))))))))
+ (lambda _
+ (substitute* '("src/gnome-shell/extension.js"
+ "src/gnome-shell/prefs.js")
+ (("@typelibPath@")
+ (string-append #$output "/lib/girepository-1.0/"))))))))
(home-page "https://github.com/Keruspe/GPaste")
(synopsis "Clipboard management system for GNOME Shell")
(description "GPaste is a clipboard manager, a tool which allows you to