summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-12-09 22:06:53 +0100
committerLudovic Courtès <ludo@gnu.org>2023-12-09 22:32:08 +0100
commit190eff1d201a099542cc1d3406bcc1eda6a980da (patch)
tree3fe324ef1a9087dd5706c455073378251cdae5bd /gnu/packages/gnome.scm
parent5cf6c96ad9ffafccf180ec2d44c740b6999c02ac (diff)
parent61f2d84e75c340c2ba528d392f522c51b8843f34 (diff)
Merge branch 'master' into core-updates
Change-Id: Iea8f10db98256f1c6cfac8bfcc82e2d44695ef3d
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm148
1 files changed, 72 insertions, 76 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 69817b0c81..7859f01aae 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -30,7 +30,7 @@
;;; Copyright © 2017, 2020, 2021 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Jovany Leandro G.C <bit4bit@riseup.net>
-;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
+;;; Copyright © 2018, 2023 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2018, 2019 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2019 Danny Milosavljevic <dannym@scratchpost.org>
@@ -51,7 +51,7 @@
;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
-;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021, 2022, 2023 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020, 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020, 2022 Michael Rohleder <mike@rohleder.de>
@@ -1891,7 +1891,7 @@ either on a local, or remote machine via a number of methods.")
(define-public gnome-commander
(package
(name "gnome-commander")
- (version "1.14.3")
+ (version "1.16.1")
(source
(origin
(method url-fetch)
@@ -1899,8 +1899,10 @@ either on a local, or remote machine via a number of methods.")
(version-major+minor version) "/"
"gnome-commander-" version ".tar.xz"))
(sha256
- (base32 "0yzx9slg632iflw9p96nlh9i50dhacq7hrzpkj8b48mr1zkxrn3q"))))
- (build-system glib-or-gtk-build-system)
+ (base32 "1cyh20nz2f81rb6di99idvw4xjn969mjhj3n2q17kzjhlv20079z"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t))
(native-inputs
(list desktop-file-utils
flex
@@ -1908,6 +1910,7 @@ either on a local, or remote machine via a number of methods.")
`(,glib "bin")
gobject-introspection
googletest
+ `(,gtk+-2 "bin")
intltool
itstool
libtool
@@ -3492,7 +3495,7 @@ for dealing with different structured file formats.")
(define-public librsvg
(package
(name "librsvg")
- (version "2.54.5")
+ (version "2.56.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/librsvg/"
@@ -3500,10 +3503,7 @@ for dealing with different structured file formats.")
"librsvg-" version ".tar.xz"))
(sha256
(base32
- "0vmfgihhf35bxn7giqiskgsflr0zxp6xyy9aynhiyk9j8l7ij0sg"))
- (modules '((guix build utils)))
- (snippet
- '(begin (delete-file-recursively "vendor")))))
+ "1xa0cxdvc6vis5ssh1i0vi2rwgcx3bll6k5i135qyd2ra77zv1za"))))
(build-system cargo-build-system)
(outputs '("out" "doc" "debug"))
(arguments
@@ -3514,55 +3514,61 @@ for dealing with different structured file formats.")
(guix build utils)
((guix build gnu-build-system) #:prefix gnu:))
#:cargo-inputs
- `(("rust-byteorder" ,rust-byteorder-1)
- ("rust-cairo-rs" ,rust-cairo-rs-0.15)
+ `(("rust-anyhow" ,rust-anyhow-1)
+ ("rust-byteorder" ,rust-byteorder-1)
+ ("rust-cairo-rs" ,rust-cairo-rs-0.17)
("rust-cast" ,rust-cast-0.3)
("rust-chrono" ,rust-chrono-0.4)
- ("rust-clap" ,rust-clap-2)
- ("rust-cssparser" ,rust-cssparser-0.28)
- ("rust-data-url" ,rust-data-url-0.1)
- ("rust-encoding" ,rust-encoding-0.2)
+ ("rust-clap" ,rust-clap-4)
+ ("rust-clap-complete" ,rust-clap-complete-4)
+ ("rust-cssparser" ,rust-cssparser-0.29)
+ ("rust-data-url" ,rust-data-url-0.2)
+ ("rust-encoding-rs" ,rust-encoding-rs-0.8)
("rust-float-cmp" ,rust-float-cmp-0.9)
- ("rust-gdk-pixbuf" ,rust-gdk-pixbuf-0.15)
- ("rust-gio" ,rust-gio-0.15)
- ("rust-glib" ,rust-glib-0.15)
+ ("rust-gdk-pixbuf" ,rust-gdk-pixbuf-0.17)
+ ("rust-gio" ,rust-gio-0.17)
+ ("rust-glib" ,rust-glib-0.17)
("rust-itertools" ,rust-itertools-0.10)
("rust-language-tags" ,rust-language-tags-0.3)
("rust-libc" ,rust-libc-0.2)
("rust-locale-config" ,rust-locale-config-0.3)
- ("rust-markup5ever" ,rust-markup5ever-0.10)
- ("rust-nalgebra" ,rust-nalgebra-0.29)
+ ("rust-markup5ever" ,rust-markup5ever-0.11)
+ ("rust-nalgebra" ,rust-nalgebra-0.32)
("rust-num-traits" ,rust-num-traits-0.2)
("rust-once-cell" ,rust-once-cell-1)
- ("rust-pango" ,rust-pango-0.15)
- ("rust-pangocairo" ,rust-pangocairo-0.15)
+ ("rust-pango" ,rust-pango-0.17)
+ ("rust-pangocairo" ,rust-pangocairo-0.17)
("rust-rayon" ,rust-rayon-1)
- ("rust-rctree" ,rust-rctree-0.4)
- ("rust-rgb" ,rust-rgb-0.8)
+ ("rust-rctree" ,rust-rctree-0.5)
("rust-regex" ,rust-regex-1)
- ("rust-selectors" ,rust-selectors-0.23)
+ ("rust-rgb" ,rust-rgb-0.8)
+ ("rust-selectors" ,rust-selectors-0.24)
("rust-string-cache" ,rust-string-cache-0.8)
+ ("rust-system-deps" ,rust-system-deps-6)
+ ("rust-thiserror" ,rust-thiserror-1)
("rust-tinyvec" ,rust-tinyvec-1)
("rust-url" ,rust-url-2)
- ("rust-xml5ever" ,rust-xml5ever-0.16))
+ ("rust-xml5ever" ,rust-xml5ever-0.17))
#:cargo-development-inputs
`(("rust-anyhow" ,rust-anyhow-1)
("rust-assert-cmd" ,rust-assert-cmd-2)
- ("rust-cairo-rs" ,rust-cairo-rs-0.15)
+ ("rust-cairo-rs" ,rust-cairo-rs-0.17)
+ ("rust-cast" ,rust-cast-0.3)
("rust-chrono" ,rust-chrono-0.4)
- ("rust-criterion" ,rust-criterion-0.3)
- ("rust-glib" ,rust-glib-0.15)
+ ("rust-criterion" ,rust-criterion-0.4)
+ ("rust-glib" ,rust-glib-0.17)
("rust-libc" ,rust-libc-0.2)
- ("rust-lopdf" ,rust-lopdf-0.26)
+ ("rust-lopdf" ,rust-lopdf-0.29)
("rust-matches" ,rust-matches-0.1)
+ ("rust-pango" ,rust-pango-0.17)
+ ("rust-pangocairo" ,rust-pangocairo-0.17)
("rust-png" ,rust-png-0.17)
("rust-predicates" ,rust-predicates-2)
("rust-proptest" ,rust-proptest-1)
("rust-serde" ,rust-serde-1)
("rust-serde-json" ,rust-serde-json-1)
("rust-tempfile" ,rust-tempfile-3)
- ("rust-test-generator" ,rust-test-generator-0.3)
- ("rust-yeslogic-fontconfig-sys" ,rust-yeslogic-fontconfig-sys-2))
+ ("rust-yeslogic-fontconfig-sys" ,rust-yeslogic-fontconfig-sys-4))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-gdk-pixbuf-thumbnailer
@@ -3586,12 +3592,9 @@ for dealing with different structured file formats.")
;; Increase reftest tolerance a bit to account for different
;; harfbuzz, pango, etc.
(setenv "RSVG_TEST_TOLERANCE" "20")
- ;; These two tests even fail after loosening the tolerance.
- (for-each delete-file
- '("tests/fixtures/reftests/bugs/730-font-scaling.svg"
- "tests/fixtures/reftests/bugs/730-font-scaling-ref.png"
- "tests/fixtures/reftests/svg1.1/text-text-03-b.svg"
- "tests/fixtures/reftests/svg1.1/text-text-03-b-ref.png"))))
+ ;; This test fails even after loosening the tolerance.
+ (substitute* "tests/src/reference.rs"
+ ((".*svg1_1_text_align_03_b_svg.*") ""))))
(add-before 'configure 'pre-configure
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "gdk-pixbuf-loader/Makefile.in"
@@ -5905,7 +5908,7 @@ services for numerous locations.")
gi-docgen
`(,glib "bin") ;for glib-mkenums
gobject-introspection
- glibc-utf8-locales
+ (libc-utf8-locales-for-target)
gsettings-desktop-schemas
pkg-config
python
@@ -7818,10 +7821,7 @@ to display dialog boxes from the commandline and shell scripts.")
(build-system meson-build-system)
(arguments
(list
- #:imported-modules `(,@%meson-build-system-modules
- (guix build syscalls))
#:modules '((guix build meson-build-system)
- (guix build syscalls)
(guix build utils)
(ice-9 match))
#:glib-or-gtk? #t
@@ -7915,22 +7915,22 @@ to display dialog boxes from the commandline and shell scripts.")
"1"))
(match (primitive-fork)
(0 ;child process
- (set-child-subreaper!)
- ;; Use tini so that signals are properly handled and
- ;; doubly-forked processes get reaped; otherwise,
- ;; python-dbusmock would waste time polling for the dbus
- ;; processes it spawns to be reaped, in vain.
- (apply execlp "tini" "--"
- "dbus-run-session" "--"
+ (apply execlp "dbus-run-session" "dbus-run-session"
"xvfb-run" "-a" "-s" (getenv "XVFB_SERVER_ARGS")
"meson" "test" "-t" "0" "--print-errorlogs"
test-options))
- (pid
- (match (waitpid pid)
- ((_ . status)
- (unless (zero? status)
- (error "`meson test' exited with status"
- status))))))))))))
+ (dbus-pid
+ (let loop ()
+ ;; Reap child processes; otherwise, python-dbusmock would
+ ;; waste time polling for the dbus processes it spawns to
+ ;; be reaped, in vain.
+ (match (waitpid WAIT_ANY)
+ ((pid . status)
+ (if (= pid dbus-pid)
+ (unless (zero? status)
+ (error "`meson test' exited with status"
+ status))
+ (loop)))))))))))))
(native-inputs
(list desktop-file-utils ;for update-desktop-database
`(,glib "bin") ;for glib-compile-schemas, etc.
@@ -7951,8 +7951,7 @@ to display dialog boxes from the commandline and shell scripts.")
pipewire
python
python-dbus
- python-dbusmock
- tini)) ;acting as init (zombie reaper)
+ python-dbusmock))
(propagated-inputs
(list gsettings-desktop-schemas-next ;required by libmutter.pc
gtk+ ;required by libmutter.pc
@@ -8264,7 +8263,7 @@ users.")
(name "network-manager")
;; Note: NetworkManager still follows the odd/even major version number
;; for development/stable releases scheme; be sure to use a stable one.
- (version "1.42.6")
+ (version "1.44.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/NetworkManager/"
@@ -8274,7 +8273,7 @@ users.")
"network-manager-meson.patch"))
(sha256
(base32
- "0y82xl84dyhdkyl98y86wspiq9iy5jz23bjzc3mvrijsfz1qlf4c"))))
+ "17zvg63jjbqdw8xyc6narirvvbbv7micbn0j7dmq0bqqgmihkjpd"))))
(build-system meson-build-system)
(outputs '("out"
"doc")) ; 8 MiB of gtk-doc HTML
@@ -8296,6 +8295,7 @@ users.")
"-Ddhcpcanon=no"
"-Dcrypto=gnutls"
"-Diwd=true"
+ "-Dnm_cloud_setup=false"
"-Dlibaudit=yes"
"-Dqt=false"
"-Ddocs=true"
@@ -8305,19 +8305,12 @@ users.")
#$output "/lib/udev")
(string-append "-Ddbus_conf_dir="
#$output "/etc/dbus-1/system.d")
-
+ (string-append "-Dmodprobe=" (search-input-file %build-inputs
+ "bin/modprobe"))
(string-append "-Ddhclient=" (search-input-file %build-inputs
- "/sbin/dhclient")))
+ "sbin/dhclient")))
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'patch-modprobe-path
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/libnm-platform/nm-platform-utils.c"
- ;; The modprobe command location is not configurable (see:
- ;; https://gitlab.freedesktop.org/NetworkManager/
- ;; NetworkManager/-/issues/1257).
- (("/sbin/modprobe")
- (search-input-file inputs "bin/modprobe")))))
(add-after 'unpack 'patch-dlopen-call-to-libjansson.so
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/libnm-glib-aux/nm-json-aux.c"
@@ -8633,7 +8626,10 @@ Cisco's AnyConnect SSL VPN.")
libsecret
network-manager
openfortivpn
- ppp))
+
+ ;; ppp < 2.5.0 is currently required:
+ ;; https://gitlab.gnome.org/GNOME/NetworkManager-fortisslvpn/-/commit/084ef529c5fb816927ca54866f66b340265aa9f6
+ ppp-2.4.9))
(home-page "https://wiki.gnome.org/Projects/NetworkManager/VPN")
(synopsis "Fortinet SSLVPN plug-in for NetworkManager")
(description
@@ -8667,7 +8663,7 @@ to virtual private networks (VPNs) via Fortinet SSLVPN.")
(define-public network-manager-applet
(package
(name "network-manager-applet")
- (version "1.32.0")
+ (version "1.34.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/network-manager-applet/"
@@ -8675,7 +8671,7 @@ to virtual private networks (VPNs) via Fortinet SSLVPN.")
"network-manager-applet-" version ".tar.xz"))
(sha256
(base32
- "0f5sxxi9rywg8mhglcyk3sqmgv5wwl4vxzar56847b852pxazdd2"))))
+ "1a55mf4ww06lqacs6zndp29ayyby5f8rgg1lp341y5kb1x3qwdmb"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -9467,7 +9463,7 @@ easy, safe, and automatic.")
(native-inputs
(list gettext-minimal
`(,glib "bin")
- glibc-utf8-locales
+ (libc-utf8-locales-for-target)
gobject-introspection
docbook-xsl
docbook-xml
@@ -9524,7 +9520,7 @@ endpoint and it understands SPARQL.")
(define-public tracker-miners
(package
(name "tracker-miners")
- (version "3.3.1")
+ (version "3.3.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/tracker-miners/"
@@ -9532,7 +9528,7 @@ endpoint and it understands SPARQL.")
"/tracker-miners-" version ".tar.xz"))
(sha256
(base32
- "151w6ljq1gk9idqfq9qs3w16vms91jnxy59c9kx6jaf0fb9cdp9y"))))
+ "1izg2xhlr64gd9pw7apa9nkf0ffyz74f22ml1ng7q60bxf0dl0yl"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t