summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-08 22:22:57 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:41 -0400
commit22bdb55a24b4129ad87230421b6ea85621dd42a0 (patch)
tree29f50c99d1aa99186e488b9b68229a9cff0c5177 /gnu/packages/gnome.scm
parent5d138a72210096b21a427bb32968c54d4a1df165 (diff)
gnu: libpeas: Update to 1.32.0.
* gnu/packages/gnome.scm (libpeas): Update to 1.32.0. [phases]{start-xserver}: Use search-input-file. [native-inputs]: Remove labels. [home-page]: Update URL.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm41
1 files changed, 22 insertions, 19 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 25ac09aa3a..096da1ab22 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3104,42 +3104,45 @@ some form of information without getting in the user's way.")
(define-public libpeas
(package
(name "libpeas")
- (version "1.30.0")
+ (version "1.32.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "18xrk1c1ixlhkmykcfiafrl2am470ws687xqvjlq40zwkcp5dx8b"))))
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "03ixrhfkywcb409dd0hybyb6i291phwy8si4kc17g29fl07m49fn"))))
(build-system meson-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(add-before 'check 'start-xserver
(lambda* (#:key inputs #:allow-other-keys)
- (let ((xorg-server (assoc-ref inputs "xorg-server"))
- (disp ":1"))
+ (let ((disp ":1"))
(setenv "DISPLAY" disp)
(setenv "XDG_CACHE_HOME" "/tmp/xdg-cache")
(setenv "XDG_CONFIG_HOME" "/tmp")
;; Tests require a running X server.
- (system (format #f "~a/bin/Xvfb ~a &" xorg-server disp))
- #t))))))
+ (system (format #f "~a ~a &"
+ (search-input-file inputs "bin/Xvfb")
+ disp))))))))
(inputs
- (list gtk+ glade3 python python-pygobject))
+ (list gtk+
+ glade3
+ python
+ python-pygobject))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("xorg-server" ,xorg-server-for-tests)))
+ (list pkg-config
+ gettext-minimal
+ `(,glib "bin")
+ gobject-introspection
+ xorg-server-for-tests))
(propagated-inputs
;; The .pc file "Requires" gobject-introspection.
(list gobject-introspection))
- (home-page "https://wiki.gnome.org/Libpeas")
+ (home-page "https://wiki.gnome.org/Projects/Libpeas")
(synopsis "GObject plugin system")
(description
"Libpeas is a gobject-based plugin engine, targeted at giving every