summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-11 20:40:10 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:56 -0400
commit629172258d836415c8906c7121c85c4f453eb56e (patch)
treec37f5bc06066909f82612fbbc9e6848e3b8fe4ca /gnu/packages/gnome.scm
parentad519b73e2ddb84f1122c9a438b20b47f1cab948 (diff)
gnu: evolution-data-server: Update to 3.45.3.
* gnu/packages/gnome.scm (evolution-data-server): Update to 3.45.3. [configure-flags]: Add -DENABLE_OAUTH2_WEBKITGTK4=OFF. [native-inputs]: Sort. [propagated-inputs]: Add glib, gtk and json-glib. Replace libsoup-minimal-2 with libsoup. [inputs]: Replace libgweather with libgweather4. Replace webkitgtk-with-libsoup2 with webkitgtk. Add pango-next. (evolution-data-server-3.44): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm47
1 files changed, 38 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 809bfafe85..eb9412dab1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7957,7 +7957,7 @@ Microsoft Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
(define-public evolution-data-server
(package
(name "evolution-data-server")
- (version "3.44.4")
+ (version "3.45.3")
(source
(origin
(method url-fetch)
@@ -7965,7 +7965,7 @@ Microsoft Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "1sxjrjr31wqbp9g4pf6dwj8rc4mi7c5fbfd489ha92ym7246bin0"))))
+ (base32 "1zjg9b77qmfin9m16rqa6cpqp1rh63pg3bcnkh25vmklslwhvq7a"))))
(build-system cmake-build-system)
(arguments
(list
@@ -7981,7 +7981,8 @@ Microsoft Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
(string-append "-DCMAKE_INSTALL_RPATH=" lib ";"
(string-append lib "/evolution-data-server;")
(string-join runpaths ";"))
- "-DENABLE_INTROSPECTION=ON" ;required for Vala bindings
+ "-DENABLE_INTROSPECTION=ON" ;required for Vala bindings
+ "-DENABLE_OAUTH2_WEBKITGTK4=OFF" ;requires webkitgtk-next
"-DWITH_PHONENUMBER=ON"))
#:phases
#~(modify-phases %standard-phases
@@ -8013,14 +8014,17 @@ Microsoft Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
intltool
pkg-config
protobuf
- vala
- python-wrapper))
+ python-wrapper
+ vala))
(propagated-inputs
;; These are all in the Requires field of .pc files.
- (list gtk+
+ (list glib
+ gtk
+ gtk+
+ json-glib
libical
libsecret
- libsoup-minimal-2
+ libsoup
nss
sqlite))
(inputs
@@ -8030,11 +8034,12 @@ Microsoft Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
gnome-online-accounts
json-glib
libcanberra
- libgweather
+ libgweather4
libphonenumber
mit-krb5
openldap
- webkitgtk-with-libsoup2))
+ pango-next ;remove after it's the default
+ webkitgtk))
(synopsis "Store address books and calendars")
(home-page "https://wiki.gnome.org/Apps/Evolution")
(description
@@ -8043,6 +8048,30 @@ contacts, tasks, and calendar information. It was originally developed for
Evolution (hence the name), but is now used by other packages as well.")
(license license:lgpl2.0)))
+;;; This version can be used for projects with dependencies stuck on libsoup2.
+(define-public evolution-data-server-3.44
+ (package
+ (inherit evolution-data-server)
+ (name "evolution-data-server")
+ (version "3.44.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32 "1sxjrjr31wqbp9g4pf6dwj8rc4mi7c5fbfd489ha92ym7246bin0"))))
+ (inputs
+ (modify-inputs (package-inputs evolution-data-server)
+ (replace "gnome-online-accounts" gnome-online-accounts-3.44)
+ (replace "libgweather4" libgweather)
+ (replace "webkitgtk" webkitgtk-with-libsoup2)))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs evolution-data-server)
+ (delete "gtk")
+ (replace "libsoup" libsoup-minimal-2)))))
+
(define-public caribou
(package
(name "caribou")