summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-20 15:56:00 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-21 00:44:04 -0400
commit6bc285e6c6f055f38d77788648ce31352a7714a5 (patch)
tree123c9cbc4b1e100c2862b38cb3218e1d2832b134 /gnu/packages/gnome.scm
parent6cc1c11d0ae1f70f8a0e912873d9e1311a9f5d04 (diff)
gnu: zeitgeist: Remove patch-docbook-xml phase.
* gnu/packages/gnome.scm (zeitgeist) [arguments]: Remove patch-docbook-xml phase. Use gexps. [native-inputs]: Add libxml2.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm46
1 files changed, 19 insertions, 27 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4f3634c389..2c2de935ed 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -697,31 +697,23 @@ of known objects without needing a central registrar.")
(base32 "07b1ahj3vd3m8srwkrh7dl3ymr7d55xiiszny44q13g06pq4svch"))))
(build-system glib-or-gtk-build-system)
(arguments
- `(#:configure-flags
- (list
- "--enable-explain-queries"
- "--enable-fts"
- "--enable-docs")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-docbook-xml
- (lambda* (#:key inputs #:allow-other-keys)
- (with-directory-excursion "doc/libzeitgeist"
- (substitute* "zeitgeist-gtkdoc-index.sgml"
- (("http://www.oasis-open.org/docbook/xml/4.3/")
- (search-input-directory inputs "/xml/dtd/docbook/"))))))
- (add-after 'patch-docbook-xml 'disable-failing-tests
- (lambda _
- (substitute* "test/direct/Makefile.am"
- ((" log-test ")
- ""))
- (substitute* "test/c/Makefile.am"
- ((" test-log ")
- ""))))
- (add-before 'bootstrap 'remove-autogen-script
- (lambda _
- ;; To honor `autoreconf -vif` by build-system.
- (delete-file "autogen.sh"))))))
+ (list #:configure-flags #~(list "--enable-explain-queries"
+ "--enable-fts"
+ "--enable-docs")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (substitute* "test/direct/Makefile.am"
+ ((" log-test ")
+ ""))
+ (substitute* "test/c/Makefile.am"
+ ((" test-log ")
+ ""))))
+ (add-before 'bootstrap 'remove-autogen-script
+ (lambda _
+ ;; To honor `autoreconf -vif` by build-system.
+ (delete-file "autogen.sh"))))))
(native-inputs
(list autoconf
automake
@@ -730,6 +722,7 @@ of known objects without needing a central registrar.")
gobject-introspection
gtk-doc/stable
libtool
+ libxml2 ;for XML_CATALOG_FILES
pkg-config
vala
xorg-server-for-tests))
@@ -742,8 +735,7 @@ of known objects without needing a central registrar.")
python-wrapper
python-rdflib
xapian))
- (propagated-inputs
- (list glib))
+ (propagated-inputs (list glib))
(synopsis "Desktop Activity Logging")
(description "Zeitgeist is a service which logs the users’s activities and
events, anywhere from files opened to websites visited and conversations. It