summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-20 15:53:42 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-21 00:44:04 -0400
commit6cc1c11d0ae1f70f8a0e912873d9e1311a9f5d04 (patch)
treed6fade297c75d3745ae10e7fa7449ad505abcc86 /gnu/packages/gnome.scm
parentadbd08e010163972dad4f25fdeb27f5024313b81 (diff)
gnu: dee: Remove patch-docbook-xml phase.
* gnu/packages/gnome.scm (dee) [arguments]: Remove patch-docbook-xml phase. Use gexps. [native-inputs]: Remove labels. Add libxml2. [inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm88
1 files changed, 39 insertions, 49 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ccddb50c2a..4f3634c389 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -627,56 +627,46 @@ of writing test cases for asynchronous interactions.")
(build-system glib-or-gtk-build-system)
(outputs '("out" "doc"))
(arguments
- `(#:configure-flags
- (list
- "--disable-maintainer-flags"
- (string-append "--with-pygi-overrides-dir="
- (assoc-ref %outputs "out")
- "/lib/python"
- ,(version-major+minor
- (package-version python))
- "/site-packages/gi/overrides")
- (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-docbook-xml
- (lambda* (#:key inputs #:allow-other-keys)
- (with-directory-excursion "doc/reference/dee-1.0"
- (substitute* "dee-1.0-docs.sgml"
- (("http://www.oasis-open.org/docbook/xml/4.3/")
- (string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/"))))))
- (add-after 'patch-docbook-xml 'disable-failing-tests
- (lambda _
- (substitute* "tests/test-icu.c"
- (("g_test_add \\(DOMAIN\"/Default/AsciiFolder\", Fixture, 0,")
- "")
- (("setup, test_ascii_folder, teardown\\);")
- ""))))
- (add-before 'check 'pre-check
- (lambda _
- ;; Tests require a running dbus-daemon.
- (system "dbus-daemon &")
- ;; For missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0"))))))
+ (list #:configure-flags
+ #~(list "--disable-maintainer-flags"
+ (string-append "--with-pygi-overrides-dir="
+ #$output "/lib/python"
+ #$(version-major+minor
+ (package-version python))
+ "/site-packages/gi/overrides")
+ (string-append "--with-html-dir="
+ #$output "/share/gtk-doc/html"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (substitute* "tests/test-icu.c"
+ (("g_test_add \\(DOMAIN\"/Default/AsciiFolder\",\
+ Fixture, 0,")
+ "")
+ (("setup, test_ascii_folder, teardown\\);")
+ ""))))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a running dbus-daemon.
+ (system "dbus-daemon &")
+ ;; For missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0"))))))
(native-inputs
- `(("dbus" ,dbus)
- ("dbus-test-runner" ,dbus-test-runner)
- ("docbook-xml" ,docbook-xml-4.3)
- ("gobject-introspection" ,gobject-introspection)
- ("gtk-doc" ,gtk-doc/stable)
- ;; Would only be required by configure flag "--enable-extended-tests".
- ;("gtx" ,gtx)
- ("pkg-config" ,pkg-config)
- ("pygobject" ,python-pygobject)
- ("python" ,python-wrapper)
- ("vala" ,vala-0.52)))
- (inputs
- `(("icu" ,icu4c)))
- (propagated-inputs
- (list glib))
+ (list dbus
+ dbus-test-runner
+ docbook-xml-4.3
+ gobject-introspection
+ gtk-doc/stable
+ ;; Would only be required by configure flag "--enable-extended-tests".
+ ;;gtx
+ libxml2 ;for XML_CATALOG_FILES
+ pkg-config
+ python-pygobject
+ python-wrapper
+ vala-0.52))
+ (inputs (list icu4c))
+ (propagated-inputs (list glib))
(synopsis "Model to synchronize multiple instances over DBus")
(description "Dee is a library that uses DBus to provide objects allowing
you to create Model-View-Controller type programs across DBus. It also consists