summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:17 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-20 11:24:40 -0400
commit73b6a5c0d8982a7b5e0a7b2d7dbf49ecda440a38 (patch)
tree650191856ec2ed942681ddefdcc9658966a5766a /gnu/packages/gnome.scm
parent78cb35793fb3dcefcc99438dc17772326e20f336 (diff)
gnu: gnome: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/gnome.scm (gnome-photos)[inputs]: Add 'bash-minimal'. (totem)[inputs]: Likewise. (d-feet)[inputs]: Likewise. (gnome-session)[inputs]: Likewise. (caribou)[inputs]: Likewise. (gnome-shell)[inputs]: Likewise. (authenticator)[inputs]: Likewise. (soundconverter)[inputs]: Likewise. (terminator)[inputs]: Likewise. (gitg)[inputs]: Likewise. (libratbag)[inputs]: Likewise. (piper)[inputs]: Likewise. (parlatype)[inputs]: Likewise. (orcfeeder)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I720f33461756950844bfeab04307c8421287f386
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm47
1 files changed, 32 insertions, 15 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e1cb7e07d7..69817b0c81 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -851,7 +851,8 @@ tomorrow, the rest of the week and for special occasions.")
itstool
pkg-config))
(inputs
- (list babl
+ (list bash-minimal
+ babl
cairo
gegl
geocode-glib
@@ -6647,7 +6648,8 @@ discovery protocols.")
(propagated-inputs
(list dconf))
(inputs
- (list gtk+
+ (list bash-minimal
+ gtk+
gdk-pixbuf
at-spi2-core
cairo
@@ -7219,7 +7221,8 @@ principles are simplicity and standards compliance.")
python-pep8
xorg-server-for-tests))
(inputs
- (list gobject-introspection
+ (list bash-minimal
+ gobject-introspection
gtk+
python-wrapper
python-pygobject))
@@ -7618,7 +7621,8 @@ such as gzip tarballs.")
pkg-config
xmlto))
(inputs
- (list elogind
+ (list bash-minimal
+ elogind
gnome-desktop
gsettings-desktop-schemas
gtk+
@@ -8243,7 +8247,8 @@ Evolution (hence the name), but is now used by other packages as well.")
;; caribou-1.0.pc refers to all these.
(list libgee libxklavier libxtst gtk+))
(inputs
- `(("clutter" ,clutter)
+ `(("bash" ,bash-minimal) ; for wrap-program
+ ("clutter" ,clutter)
("dconf" ,dconf)
("gtk+-2" ,gtk+-2)
("python-pygobject" ,python-pygobject)))
@@ -9277,6 +9282,7 @@ printf '~a is deprecated. Use the \"gnome-extensions\" CLI or \
xorg-server-for-tests))
(inputs
(list accountsservice
+ bash-minimal
caribou
docbook-xsl
evolution-data-server
@@ -10195,7 +10201,8 @@ specified duration and save it as a GIF encoded animated image file.")
`(,gtk+ "bin")
pkg-config))
(inputs
- (list gsettings-desktop-schemas
+ (list bash-minimal
+ gsettings-desktop-schemas
gtk+
libhandy-0.0
libsecret
@@ -11532,14 +11539,18 @@ mp3, Ogg Vorbis and FLAC")
(gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
(wrap-program (string-append out "/bin/soundconverter")
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
- `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))))
- #t)))))
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))) #t)))))
(native-inputs
`(("intltool" ,intltool)
("pkg-config" ,pkg-config)
("glib:bin" ,glib "bin")))
(inputs
- (list gtk+ python python-pygobject gstreamer gst-plugins-base))
+ (list bash-minimal
+ gtk+
+ python
+ python-pygobject
+ gstreamer
+ gst-plugins-base))
(home-page "https://soundconverter.org/")
(synopsis "Convert between audio formats with a graphical interface")
(description
@@ -11825,7 +11836,8 @@ advanced image management tool")
("python-pytest-runner" ,python-pytest-runner)
("python-pytest" ,python-pytest)))
(inputs
- `(("cairo" ,cairo)
+ `(("bash" ,bash-minimal) ; for wrap-program
+ ("cairo" ,cairo)
("dbus-glib" ,dbus-glib)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)
@@ -12010,7 +12022,8 @@ higher level porcelain stuff.")
(wrap-program prog
`("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))))))))
(inputs
- (list glib
+ (list bash-minimal
+ glib
gsettings-desktop-schemas
gspell
gtk+
@@ -12703,7 +12716,8 @@ It uses pandoc as back-end for parsing Markdown.")
(list valgrind)
'())))
(inputs
- `(("glib" ,glib)
+ `(("bash" ,bash-minimal) ; for wrap-program
+ ("glib" ,glib)
("json-glib" ,json-glib)
("libevdev" ,libevdev)
("libsystemd" ,elogind)
@@ -12774,7 +12788,8 @@ your operating-system definition:
gobject-introspection
pkg-config))
(inputs
- (list adwaita-icon-theme
+ (list bash-minimal
+ adwaita-icon-theme
gtk+
guile-3.0 ;for wrap-script
libratbag
@@ -12837,7 +12852,8 @@ provided there is a DBus service present:
pkg-config
yelp-tools))
(inputs
- (list gst-plugins-base
+ (list bash-minimal
+ gst-plugins-base
gst-plugins-good
gstreamer
gtk+
@@ -13281,7 +13297,8 @@ world.")
("pkg-config" ,pkg-config)
("xmllint" ,libxml2)))
(inputs
- `(("enchant" ,enchant)
+ `(("bash" ,bash-minimal) ; for wrap-program
+ ("enchant" ,enchant)
("glib" ,glib)
("goocanvas" ,goocanvas)
("gtk" ,gtk+)