summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-10 01:18:17 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:51 -0400
commit87c5dd8ea5535df93f3705177cff1c19800999c5 (patch)
tree168a2bf493c4a1bc49c878007bb2ce6949feafd7 /gnu/packages/gnome.scm
parent0e60bdf0dcc684d4593a074bc0814c6c5ff77ec5 (diff)
gnu: nautilus: Update to 42.2 and enable tests.
* gnu/packages/gnome.scm (nautilus): Update to 42.2. [patches]: Replace nautilus-add-libportal-gtk3.patch with nautilus-disable-tracker-tests.patch. [tests?]: Delete argument. [phases]: Use gexps. {check}: Move after install. {pre-check}: New phase. [native-inputs]: Replace intltool with gettext-minimal. Add python-pygobject. [inputs]: Remove libsoup-minimal-2. * gnu/packages/patches/nautilus-add-libportal-gtk3.patch: Delete file. * gnu/packages/patches/nautilus-disable-tracker-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm65
1 files changed, 35 insertions, 30 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index bc43e191f8..65c6156966 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9420,7 +9420,7 @@ shared object databases, search tools and indexing.")
(define-public nautilus
(package
(name "nautilus")
- (version "41.1")
+ (version "42.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -9428,28 +9428,27 @@ shared object databases, search tools and indexing.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0bsqh241m43x3qb3z0mjakjic610ncl95zhjdgls649phnc30qry"))
+ "1cncyiyh79w1id6a6s2f0rxmgwl65lp4ml4afa0z35jrnwp2s8cr"))
(patches
- ;; This patch is already upstream and can be removed next
- ;; release.
- (search-patches "nautilus-add-libportal-gtk3.patch"))))
+ (search-patches "nautilus-disable-tracker-tests.patch"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'make-extensible
- (lambda _
- (substitute* "src/nautilus-module.c"
- (("static gboolean initialized = FALSE;" all)
- (string-append all "
+ (list
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'make-extensible
+ (lambda _
+ (substitute* "src/nautilus-module.c"
+ (("static gboolean initialized = FALSE;" all)
+ (string-append all "
const char *extension_path;
char **extension_dirs, **d;
")
- )
- (("load_module_dir \\(NAUTILUS_EXTENSIONDIR\\);" all)
- (string-append all
- "
+ )
+ (("load_module_dir \\(NAUTILUS_EXTENSIONDIR\\);" all)
+ (string-append all
+ "
extension_path = g_getenv (\"NAUTILUS_EXTENSION_PATH\");
if (extension_path)
{
@@ -9459,21 +9458,28 @@ if (extension_path)
g_strfreev(extension_dirs);
}
")))))
- (add-after 'unpack 'skip-gtk-update-icon-cache
- ;; Don't create 'icon-theme.cache'.
- (lambda _
- (substitute* "build-aux/meson/postinstall.py"
- (("gtk-update-icon-cache") "true")))))
- ;; XXX: FAIL: check-nautilus
- ;; Settings schema 'org.gnome.nautilus.preferences' is not installed
- #:tests? #f))
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "build-aux/meson/postinstall.py"
+ (("gtk-update-icon-cache") "true"))))
+ (delete 'check)
+ (add-after 'install 'check
+ (assoc-ref %standard-phases 'check))
+ (add-before 'check 'pre-check
+ (lambda _
+ (setenv "HOME" "/tmp") ;some tests require a writable HOME
+ (setenv "XDG_DATA_DIRS"
+ (string-append (getenv "XDG_DATA_DIRS")
+ ":" #$output "/share")))))))
(native-inputs
- (list desktop-file-utils ; for update-desktop-database
- `(,glib "bin") ; for glib-mkenums, etc.
+ (list desktop-file-utils ;for update-desktop-database
+ `(,glib "bin") ;for glib-mkenums, etc.
+ gettext-minimal
gobject-introspection
- intltool
pkg-config
- python))
+ python
+ python-pygobject))
(inputs
(list dconf
gexiv2
@@ -9487,7 +9493,6 @@ if (extension_path)
libportal
libseccomp
libselinux
- libsoup-minimal-2 ; to satisfy tracker dependencies
tracker
tracker-miners
;; XXX: gtk+ is required by libnautilus-extension.pc