summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-20 09:53:35 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:42 +0200
commit9c97342939c0d891295768fb39804fc5f8d954e4 (patch)
tree711475be813f0eafae230412548d1ccddb4258d3 /gnu/packages/gnome.scm
parent6d45f24dee5408a54e71ff36bdfc9d9f801ec52f (diff)
gnu: librsvg: Honor the #:tests flag.
* gnu/packages/gnome.scm (librsvg)[arguments]: Adjust the custom 'check phase to honor the #:tests? flag. Change-Id: I53c2fac1c5625d9b73adf5929e148eb4ecf18b89
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0be935585d..e376929e22 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3632,9 +3632,10 @@ for dealing with different structured file formats.")
(replace 'build
(assoc-ref gnu:%standard-phases 'build))
(replace 'check
- (lambda* args
- ((assoc-ref gnu:%standard-phases 'check)
- #:test-target "check")))
+ (lambda* (#:key tests? #:allow-other-keys #:rest args)
+ (when tests?
+ ((assoc-ref gnu:%standard-phases 'check)
+ #:test-target "check"))))
(replace 'install
(assoc-ref gnu:%standard-phases 'install)))))
(native-inputs (list `(,glib "bin") gobject-introspection pkg-config vala))