summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-05-16 18:24:14 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-05-21 22:18:46 +0200
commit9d77f6562b97e9598f651b491ce45a4b84a83656 (patch)
treecf5a01301f9be34842273034cd57747501c15f20 /gnu/packages/gnome.scm
parent1310286dc684738b750e67777794775ae67bc61c (diff)
gnu: geary: Update to 43.0.
* gnu/packages/gnome.scm (geary): Update to 43.0. [arguments]<#:phases>: Drop ‘disable-failing-tests’ and ‘generate-vapis’. Rename ‘disable-postinstall-script’ to ‘skip-gtk-update-icon-cache’ and adjust accordingly. [inputs]: Replace folks-with-libsoup2 with folks. Replace gnome-online-accounts-3.44 with gnome-online-accounts. Replace webkitgtk-with-libsoup2 with webkitgtk. [native-inputs]: Replace vala-0.52 with vala. Add gnutls.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm40
1 files changed, 13 insertions, 27 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 81bc6c04e9..bf5420b1f0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12306,16 +12306,16 @@ non-privileged user.")
(define-public geary
(package
(name "geary")
- (version "40.0")
+ (version "43.0")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://gitlab.gnome.org/GNOME/geary.git")
- (commit (string-append "gnome-" version))))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "04hvw86r8sczvjm1z3ls5y5y5h6nyfb648rjkfx05ib00mqq5v1x"))))
+ "05b8c5ljzx1ly7wq8jzpv8psxmsdlz395sr17xwj49nh495nflz5"))))
(build-system meson-build-system)
(arguments
(list #:glib-or-gtk? #t
@@ -12323,27 +12323,12 @@ non-privileged user.")
#~(list "-Dprofile=release")
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda _
- (substitute* "test/test-client.vala"
- (("client.add_suite\\(new Application.CertificateManagerTest\\(\\).suite\\);")
- ""))
- (substitute* "test/test-engine.vala"
- (("engine.add_suite\\(new Geary.RFC822.MessageDataTest\\(\\).suite\\);")
- ""))))
- (add-after 'unpack 'generate-vapis
- (lambda _
- ;; It’s not possible to generate the GMime vapi, because
- ;; there’s custom metadata that gmime didn’t
- ;; install. Thus, the vapi should be built and installed
- ;; with gmime.
- (copy-file #$(file-append gmime "/share/vala/vapi/gmime-3.0.vapi")
- "bindings/vapi/gmime-3.0.vapi")))
- (add-after 'unpack 'disable-postinstall-script
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
(lambda _
- (substitute* "build-aux/post_install.py"
- (("gtk-update-icon-cache")
- "true"))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
(add-before 'check 'setup-home
(lambda _
;; Tests require a writable HOME.
@@ -12354,11 +12339,11 @@ non-privileged user.")
(setenv "DISPLAY" ":1"))))))
(inputs
(list enchant
- folks-with-libsoup2
+ folks
gcr
glib
gmime
- gnome-online-accounts-3.44
+ gnome-online-accounts
gsettings-desktop-schemas
gspell
gsound
@@ -12373,7 +12358,7 @@ non-privileged user.")
libstemmer
libunwind
sqlite
- webkitgtk-with-libsoup2
+ webkitgtk
ytnef))
(native-inputs
(list appstream-glib
@@ -12381,13 +12366,14 @@ non-privileged user.")
desktop-file-utils
gettext-minimal
`(,glib "bin")
+ gnutls ; for certtool
gobject-introspection
itstool
libarchive
libxml2
pkg-config
python-minimal
- vala-0.52
+ vala
xorg-server-for-tests))
(synopsis "GNOME email application built around conversations")
(description