summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-01-16 17:38:38 +0100
committerLudovic Courtès <ludo@gnu.org>2024-06-17 22:55:27 +0200
commitaa7612e40bbbd4873668804c70f7ea5a3cb06b1f (patch)
tree45074b19b56fa39877665dda9ea6c8c8fe237b87 /gnu/packages/gnome.scm
parent0f082944991ce6e6a5b745a5cce4e6f63d5e22ae (diff)
gnu: evolution-data-server: Use C.UTF-8 locale in test.
* gnu/packages/gnome.scm (evolution-data-server): Use C.UTF-8 locale in test. Change-Id: I8e35a9c96cc89bcd19d8e00472c2ccadf2bd5875
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 37088f42f9..59c65262cc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8267,6 +8267,10 @@ Microsoft Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
(delete-file-recursively "tests/book-migration")
(substitute* "tests/CMakeLists.txt"
(("add_subdirectory\\(book-migration\\)") ""))))
+ (add-after 'unpack 'patch-locale-in-test
+ (lambda _
+ (substitute* "tests/libebook/client/test-book-client-custom-summary.c"
+ (("en_US\\.UTF-8") "C.UTF-8"))))
(add-after 'unpack 'patch-paths
(lambda _
(substitute* '("tests/test-server-utils/e-test-server-utils.c"