summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-08 23:58:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:43 -0400
commitc2a2c5fc22804e9cb03c00bdab638049cddeb374 (patch)
tree4a06c441ec29c99be215f2f894c8309332761f6b /gnu/packages/gnome.scm
parent048380f4ed415ec4bc3ca6b0afa8e05f584d39c1 (diff)
gnu: drawing: Update to 1.0.1.
* gnu/packages/gnome.scm (drawing): Update to 1.0.1. [imported-modules, modules]: New arguments. [phases]{disable-postinstall-script}: New phase. {python-and-gi-wrap}: Simplify using the search-input-file and site-packages procedures. [native-inputs]: Remove labels. Add itstool and python. [inputs]: Add bash-minimal and python.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm54
1 files changed, 30 insertions, 24 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4454fdbcb6..399e0b487d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4353,7 +4353,7 @@ engineering.")
(define-public drawing
(package
(name "drawing")
- (version "0.8.3")
+ (version "1.0.1")
(source
(origin
(method git-fetch)
@@ -4362,36 +4362,42 @@ engineering.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0wz9p47riyy3h8b0sqsb6bx416hc6d1a1wyzlfmsxkrqrkwcjcm8"))))
+ (base32 "12xb522i7dxshw2ig12ald750fynlxan1lwz6gsxfa9p4ap2qypn"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((prog (string-append (assoc-ref outputs "out")
- "/bin/drawing"))
- (pylib (string-append (assoc-ref outputs "out")
- "/lib/python"
- ,(version-major+minor
- (package-version python))
- "/site-packages")))
- (wrap-program prog
- `("PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH") ,pylib))
- `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))))))))
+ (list
+ #:glib-or-gtk? #t
+ #:imported-modules `(,@%meson-build-system-modules
+ (guix build python-build-system))
+ #:modules '((guix build meson-build-system)
+ ((guix build python-build-system) #:prefix python:)
+ (guix build utils))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-postinstall-script
+ (lambda _
+ (setenv "DESTDIR" "/")))
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs "bin/drawing")
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")
+ ,(python:site-packages inputs outputs)))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
(native-inputs
- `(("desktop-file-utils" ,desktop-file-utils)
- ("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("gtk+:bin" ,gtk+ "bin")
- ("pkg-config" ,pkg-config)))
+ (list desktop-file-utils
+ gettext-minimal
+ `(,glib "bin")
+ gobject-introspection
+ itstool
+ pkg-config
+ python))
(inputs
- (list librsvg
+ (list bash-minimal
+ librsvg
gsettings-desktop-schemas
gtk+
pango
+ python
python-pycairo
python-pygobject))
(home-page "https://maoschanz.github.io/drawing/")