summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorSughosha <sughosha@proton.me>2022-09-20 06:00:58 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-21 06:26:56 +0200
commitd6a16a1dc4a4dd05a7b72080977dff3229ce5ce4 (patch)
tree11053521e123d6ea281d97e3cd6c5c603a66246b /gnu/packages/gnome.scm
parentf256614891335e250207edab129bdf8601c22774 (diff)
gnu: Add gnome-text-editor.
* gnu/packages/gnome.scm (gnome-text-editor): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e9db5bac95..325754cd5d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5474,6 +5474,39 @@ It supports several profiles, multiple tabs and implements several
keyboard shortcuts.")
(license license:gpl3+)))
+(define-public gnome-text-editor
+ (package
+ (name "gnome-text-editor")
+ (version "42.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gnome-text-editor/"
+ (version-major version) "/"
+ "gnome-text-editor-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1nn53iv2a82kkqkg5jy0bqh2b2wzg7g4a6w8q3qsis5wvj64lvg5"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:glib-or-gtk? #t))
+ (native-inputs (list pkg-config
+ cmake
+ gettext-minimal
+ desktop-file-utils
+ appstream-glib
+ `(,glib "bin")
+ `(,gtk "bin")
+ itstool))
+ (inputs (list gtk gtksourceview libadwaita enchant))
+ (home-page "https://gitlab.gnome.org/GNOME/gnome-text-editor")
+ (synopsis "GNOME text editor")
+ (description
+ "GNOME Text Editor is a simple text editor that focuses on session
+management. It keeps track of changes and state even if you quit the
+application. You can come back to your work even if you've never saved it to a
+file.")
+ (license license:gpl3+)))
+
(define-public colord-minimal
(package
(name "colord-minimal")