summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-14 22:19:57 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-14 22:21:41 -0400
commit261bc8f02885d89faed0deb682405a83d6c9d535 (patch)
tree87358429f8242e69148d4f0d0920fe0903f067b2 /gnu/packages/gnome.scm
parentd9b7982ba58fdea0934b60a81f507440a56c82ee (diff)
gnu: nautilus: Simplify how tracker tests are disabled.
* gnu/packages/gnome.scm (nautilus)[source]: Remove patches field. [phases]{disable-tracker-tests}: New phase. * gnu/packages/patches/nautilus-disable-tracker-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cc8e2a0396..5a3ae2659d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9519,15 +9519,20 @@ shared object databases, search tools and indexing.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1cncyiyh79w1id6a6s2f0rxmgwl65lp4ml4afa0z35jrnwp2s8cr"))
- (patches
- (search-patches "nautilus-disable-tracker-tests.patch"))))
+ "1cncyiyh79w1id6a6s2f0rxmgwl65lp4ml4afa0z35jrnwp2s8cr"))))
(build-system meson-build-system)
(arguments
(list
#:glib-or-gtk? #t
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-tracker-tests
+ ;; The tracker test hangs in the build container (see:
+ ;; https://gitlab.gnome.org/GNOME/nautilus/-/issues/2486).
+ (lambda _
+ (substitute* "test/automated/displayless/meson.build"
+ (("^foreach t: tracker_tests" all)
+ (string-append "tracker_tests = []\n" all)))))
(add-after 'unpack 'make-extensible
(lambda _
(substitute* "src/nautilus-module.c"