summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-13 16:11:14 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-13 16:11:14 +0100
commit622df12ef389c9e91f68ae10c54c043f34828c83 (patch)
tree888542636c0717727d52a4cd56d42338601e661a /gnu/packages/gnome.scm
parent952c691b51f8f5d56df69686c2785414709c7949 (diff)
parent8a0910e042ad1670435613e06458a6fb2c4131c4 (diff)
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 26aeefff4c..7397148c2b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
;;; Copyright © 2015, 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015-2020, 2023, 2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017, 2018, 2021 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015-2024 Efraim Flashner <efraim@flashner.co.il>
@@ -7943,7 +7943,17 @@ to display dialog boxes from the commandline and shell scripts.")
;; let's disable them as well.
;; See <https://gitlab.gnome.org/GNOME/mutter/-/issues/2125>
(substitute* "src/tests/clutter/conform/meson.build"
- (("'timeline.*',") ""))))
+ (("'timeline.*',") ""))
+
+ ;; On i686-linux this test fails with a dbus error. This seems
+ ;; to be fine in later versions, so this workaround can probably
+ ;; be removed soon.
+ #$@(if (string=? "i686-linux" (or (%current-target-system)
+ (%current-system)))
+ #~((substitute* "src/tests/wayland-unit-tests.c"
+ (("g_test_add_func \\(\"/wayland/toplevel/activation\",") "")
+ (("^ toplevel_activation\\);") "")))
+ #~())))
(replace 'check
(lambda* (#:key tests? test-options parallel-tests?
#:allow-other-keys)