summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-12 22:02:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-02-12 22:04:22 +0100
commitbb4f0509b7cce750fc944e604aa919ea89910ea7 (patch)
treef91b5526d1ffdead2ce7e4a775ea8d8377554aa3 /gnu/packages/gnome.scm
parentbb92a4d7bc71197a51eea9075387c5313f299085 (diff)
gnu: mutter: Disable one test when building for i686-linux.
This test no longer fails in future versions, so this is only a temporary workaround. * gnu/packages/gnome.scm (mutter)[arguments]: Conditionally disable the activation test on i686-linux. Change-Id: Ic8552355971b9926b7f72c228edf881a1c0cea1e
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6f22529dd7..953bd817ed 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
;;; Copyright © 2015, 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015-2020, 2023, 2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017, 2018, 2021 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015-2024 Efraim Flashner <efraim@flashner.co.il>
@@ -7911,7 +7911,17 @@ to display dialog boxes from the commandline and shell scripts.")
;; let's disable them as well.
;; See <https://gitlab.gnome.org/GNOME/mutter/-/issues/2125>
(substitute* "src/tests/clutter/conform/meson.build"
- (("'timeline.*',") ""))))
+ (("'timeline.*',") ""))
+
+ ;; On i686-linux this test fails with a dbus error. This seems
+ ;; to be fine in later versions, so this workaround can probably
+ ;; be removed soon.
+ #$@(if (string=? "i686-linux" (or (%current-target-system)
+ (%current-system)))
+ #~((substitute* "src/tests/wayland-unit-tests.c"
+ (("g_test_add_func \\(\"/wayland/toplevel/activation\",") "")
+ (("^ toplevel_activation\\);") "")))
+ #~())))
(replace 'check
(lambda* (#:key tests? test-options parallel-tests?
#:allow-other-keys)