summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-09-15 15:46:14 +0800
committer宋文武 <iyzsong@gmail.com>2016-09-15 15:48:26 +0800
commitab179eaf982b7ac721891126dbf7e55c6dc36f5d (patch)
treee73ae1e815c3198b57a4a7c5ba8e1e1603c7edf0 /gnu/packages/gnome.scm
parent5467ea6200e7cf9fa57f340849b6ec1becc87b3d (diff)
gnu: Add gnome-dictionary.
* gnu/packages/gnome.scm (gnome-dictionary): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3151fe2699..6dab1d79e8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5165,6 +5165,36 @@ Microsoft SkyDrive and Hotmail, using their REST protocols.")
desktop. It supports multiple calendars, monthly view and yearly view.")
(license license:gpl3+)))
+(define-public gnome-dictionary
+ (package
+ (name "gnome-dictionary")
+ (version "3.20.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "08b1f5s5aqka3dwxnzmwr2fmyddjm9xw7zmqsf8r5zvfsivn7czg"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)
+ ("xmllint" ,libxml2)))
+ (inputs
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gtk+" ,gtk+)))
+ (home-page "https://wiki.gnome.org/Apps/Dictionary")
+ (synopsis "Look up words in dictionary sources")
+ (description
+ "GNOME Dictionary can look for the definition or translation of a word in
+existing databases over the internet.")
+ (license license:gpl3+)))
+
(define-public gnome-tweak-tool
(package
(name "gnome-tweak-tool")