summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2022-10-13 11:19:10 +0100
committerChristopher Baines <mail@cbaines.net>2022-11-03 17:39:45 +0100
commit754f260753fb6ebe28325616bc08336a184e4621 (patch)
tree79d1e32f2c9fb5f04811036a94d3718bdef380f1 /gnu/packages/gnome.scm
parentdde299df48cffb487b3378cbbd0fcbd03fcfd0e1 (diff)
gnu: gnome: Include aarch64 in librsvg-for-system.
As the current librsvg currently builds for aarch64-linux as well as x86_64-linux. * gnu/packages/gnome.scm (librsvg-for-system): Use librsvg for aarch64.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 40c1379207..1246ac22b3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3753,8 +3753,10 @@ diagrams.")
(system (or (%current-target-system)
(%current-system))))
;; Since librsvg 2.50 depends on Rust, and Rust is only correctly supported
- ;; on x86_64 so far, use the ancient C version on other platforms (FIXME).
- (if (string-prefix? "x86_64-" system)
+ ;; on x86_64 and aarch64 so far, use the ancient C version on other
+ ;; platforms (FIXME).
+ (if (or (string-prefix? "x86_64-" system)
+ (string-prefix? "aarch64-" system))
librsvg
librsvg-2.40))