summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-10 11:35:50 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-10 11:35:50 +0200
commit3a4de6b2d2fdb515c8186cbceab4259aab91cadf (patch)
tree7eaa4544ba397ce3493c26679ee2eafe76f8e448 /gnu/packages/gnome.scm
parentcaaf1933a453e7f3f8d7444f2c97dac3f8a93e1c (diff)
gnu: Add missing quotes in phase names passed to 'modify-phases'.
This is a followup to f8503e2. * gnu/packages/gnome.scm (glib-networking): Add missing quotes before phase names passed to 'modify-phases'. (libsoup): Likewise. (gnome-terminal): Likewise. (colord): Likewise. (geoclue): Likewise. * gnu/packages/gtk.scm (at-spi2-core, at-spi2-atk): Likewise. * gnu/packages/haskell.scm (ghc-network): Likewise. * gnu/packages/imagemagick.scm (perl-image-magick): Likewise. * gnu/packages/video.scm (aalib): Likewise. * gnu/packages/web.scm (nginx): Likewise.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 356cfe0999..55a4978480 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1654,7 +1654,7 @@ library.")
'("--with-ca-certificates=no")
#:phases
(modify-phases %standard-phases
- (add-before configure patch-giomoduledir
+ (add-before 'configure 'patch-giomoduledir
;; Install GIO modules into $out/lib/gio/modules.
(lambda _
(substitute* "configure"
@@ -1702,14 +1702,14 @@ library.")
"/lib/gio/modules"))
#:phases
(modify-phases %standard-phases
- (add-before configure disable-unconnected-socket-test
+ (add-before 'configure 'disable-unconnected-socket-test
;; This test fails due to missing /etc/nsswitch.conf
;; in the build environment.
(lambda _
(substitute* "tests/socket-test.c"
((".*/sockets/unconnected.*") ""))
#t))
- (add-before check unset-LC_ALL
+ (add-before 'check 'unset-LC_ALL
;; The 'check-local' target runs 'env LANG=C sort -u',
;; unset 'LC_ALL' to make 'LANG' working.
(lambda _
@@ -1852,7 +1852,7 @@ floating in an ocean using only your brain and a little bit of luck.")
"--without-nautilus-extension")
#:phases
(modify-phases %standard-phases
- (add-before configure patch-/bin/true
+ (add-before 'configure 'patch-/bin/true
(lambda _
(substitute* "configure"
(("/bin/true") (which "true"))))))))
@@ -1913,14 +1913,14 @@ keyboard shortcuts.")
"/lib/udev/rules.d"))
#:phases
(modify-phases %standard-phases
- (add-before configure patch-/bin/true
+ (add-before 'configure 'patch-/bin/true
(lambda _
(substitute* "configure"
(("/bin/true") (which "true")))
(substitute* "src/Makefile.in"
(("if test -w \\$\\(DESTDIR\\)\\$\\(prefix\\)/;")
"if test -w $(DESTDIR)$(localstatedir);"))))
- (add-before build set-cc
+ (add-before 'build 'set-cc
(lambda _
;; Set $CC so that g-ir-scanner works.
(setenv "CC" "gcc")
@@ -1971,7 +1971,7 @@ output devices.")
"--with-dbus-service-user=geoclue")
#:phases
(modify-phases %standard-phases
- (add-before configure patch-/bin/true
+ (add-before 'configure 'patch-/bin/true
(lambda _
(substitute* "configure"
(("/bin/true") (which "true"))))))))