summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2014-12-18 21:48:43 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-01-12 18:00:08 +0100
commit3d243e9c45b83bf7a4bab0514dc6830c29bb2ea5 (patch)
treec70ee661c5316cdeebd5d868a5eb97a21d6fb369 /gnu/packages/gnome.scm
parentbeb8dc0007f447a0d20e1691b41594fb9d810b83 (diff)
gnu: evince: Add inputs.
* gnu/packages/gnome.scm (evince): Add 'dconf' and 'libcanberra' inputs. Remove custom phase 'set-mime-search-path which is now handled by glib-or-gtk-build-system.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm18
1 files changed, 4 insertions, 14 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ee143f3627..4fea27a865 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -220,19 +220,7 @@ and keep up to date translations of documentation.")
;; FIXME: Tests fail with:
;; ImportError: No module named gi.repository
;; Where should that module come from?
- #:tests? #f
-
- #:phases (alist-cons-after
- 'install 'set-mime-search-path
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Wrap 'evince' so that it knows where MIME info is.
- (let ((out (assoc-ref outputs "out"))
- (mime (assoc-ref inputs "shared-mime-info")))
- (wrap-program (string-append out "/bin/evince")
- `("XDG_DATA_DIRS" ":" prefix
- ,(list (string-append mime "/share")
- (string-append out "/share"))))))
- %standard-phases)))
+ #:tests? #f))
(inputs
`(("libspectre" ,libspectre)
;; ("djvulibre" ,djvulibre)
@@ -251,7 +239,9 @@ and keep up to date translations of documentation.")
("libsm" ,libsm)
("libice" ,libice)
("shared-mime-info" ,shared-mime-info)
-
+ ("dconf" ,dconf)
+ ("libcanberra" ,libcanberra)
+
;; For tests.
("dogtail" ,python2-dogtail)))
(native-inputs