summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-20 23:39:18 -0400
committerMark H Weaver <mhw@netris.org>2015-06-23 01:04:53 -0400
commit607a04ae800d86b7e1c12e153b5ee6461bca8145 (patch)
tree7326c0a555ac9f67a4d3e354601e1f8dfeb2c3f7 /gnu/packages/gnome.scm
parent86d6a893b35bcb3d14490b9bbb36c495e7377401 (diff)
gnu: Add gom.
* gnu/packages/gnome.scm (gom): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e8d143029d..aa19d1c43d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2656,3 +2656,35 @@ It provides a GStreamer sink to upload frames to GL and an actor that
implements the ClutterGstPlayer interface using playbin. Clutter is an Open
GL based interactive canvas library.")
(license license:lgpl2.0+)))
+
+(define-public gom
+ (package
+ (name "gom")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1x9qgviszzh59d009jd13k0pdxzv9w4dmwp3wszbsk3qxr3fnlbr"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("gobject-introspection" ,gobject-introspection)))
+ (inputs
+ `(("glib" ,glib)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("sqlite" ,sqlite)))
+ ;; XXX TODO: Figure out how to run the test suite.
+ (arguments `(#:tests? #f))
+ (home-page "https://wiki.gnome.org/Projects/Gom")
+ (synopsis "Object mapper from GObjects to SQLite")
+ (description
+ "Gom provides an object mapper from GObjects to SQLite. It helps you
+write applications that need to store structured data as well as make complex
+queries upon that data.")
+ (license license:lgpl2.1+)))