summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-05-21 05:26:27 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:53:44 +0200
commit2e6bc59539228224a8909ebd9c0fb18280d36201 (patch)
tree21dcd8e4f1475ba4a38e3591a48db9bc9f92b695 /gnu/packages/gnome.scm
parent5f8ea8e49179957a6f39341b0b5454f5214ae4af (diff)
gnu: Add krb5-auth-dialog.
* gnu/packages/gnome.scm (krb5-auth-dialog): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f6796f1187..5281193406 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -259,6 +259,39 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public krb5-auth-dialog
+ (package
+ (name "krb5-auth-dialog")
+ (version "3.26.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1w91gsvmifqhiam3xqf88i5rk2w6qadjalmbvvamjdc37j0vdc6x"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("libxml2" ,libxml2)
+ ("pkg-config" ,pkg-config)
+ ("python-wrapper" ,python-wrapper)))
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("libnotify" ,libnotify)
+ ("mit-krb5" ,mit-krb5)
+ ("network-manager" ,network-manager)))
+ (synopsis "Popup dialogs for Kerberos 5")
+ (description "krb5-auth-dialog is a simple dialog that monitors Kerberos
+tickets, and pops up a dialog when they are about to expire.")
+ (home-page "https://gitlab.gnome.org/GNOME/krb5-auth-dialog")
+ (license license:gpl2+)))
+
(define-public notification-daemon
(package
(name "notification-daemon")