summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-11-10 15:52:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-11-10 15:55:16 +0200
commit56ccafbe7c4780c0bd69e76afe12311a4b8ac53a (patch)
treefc31852359a3453efb720c6856cbd5dc2bcbbb6c /gnu/packages/gnome.scm
parentc06d8ba5ee60427af4273b8ca1e02f4447b0db37 (diff)
gnu: librsvg: Skip test which fails on aarch64-linux.
* gnu/packages/gnome.scm (librsvg)[arguments]: Add a phase to remove the failing test.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 95ba7af240..5a9d145ece 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1191,7 +1191,14 @@ dealing with different structured file formats.")
;; Drop the 'loaders.cache' file, it's in gdk-pixbuf+svg.
(("gdk_pixbuf_cache_file = .*$")
"gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n")))
- %standard-phases)))
+ (alist-cons-after
+ 'unpack 'remove-failing-test
+ ;; This test fails on aarch64.
+ (lambda _
+ (delete-file "tests/fixtures/reftests/bugs/777834-empty-text-children.svg")
+ (delete-file "tests/fixtures/reftests/bugs/777834-empty-text-children-ref.png")
+ #t)
+ %standard-phases))))
(native-inputs
`(("pkg-config" ,pkg-config)
("glib" ,glib "bin") ; glib-mkenums, etc.