summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-05-23 10:09:29 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:54:03 +0200
commit56db7a6613637b0696cb6cd40f7e70bed43627c1 (patch)
treec2f5d136d41f1fd55ac7ec6994b8519620d820cf /gnu/packages/gnome.scm
parent1aefe650075b050a0e79dffcd6fdba140323d220 (diff)
gnu: Add gnome-photos.
* gnu/packages/gnome.scm (gnome-photos): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm71
1 files changed, 71 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e83004fb08..bf5f71e1c2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -107,6 +107,7 @@
#:use-module (gnu packages game-development)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages gimp)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
@@ -260,6 +261,76 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public gnome-photos
+ (package
+ (name "gnome-photos")
+ (version "3.34.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "06ml5sf8xhpan410msqz085hmfc7082d368pb82yq646y9pcfn9w"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:configure-flags
+ (list "-Ddogtail=false" ; Not available
+ ;; Required for RUNPATH validation.
+ (string-append "-Dc_link_args=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib/gnome-photos"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-gnome-photos
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let*
+ ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/gnome-photos")
+ `("GRL_PLUGIN_PATH" = (,(getenv "GRL_PLUGIN_PATH")))))
+ #t)))))
+ (native-inputs
+ `(("dbus" ,dbus)
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("gettext" ,gettext-minimal)
+ ("git" ,git-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gtk+:bin" ,gtk+ "bin")
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("babl" ,babl)
+ ("cairo" ,cairo)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("gegl" ,gegl)
+ ("geocode-glib" ,geocode-glib)
+ ("gexiv2" ,gexiv2)
+ ("gnome-online-accounts" ,gnome-online-accounts)
+ ("gnome-online-miners" ,gnome-online-miners)
+ ("grilo" ,grilo)
+ ("grilo-plugins" ,grilo-plugins)
+ ("gtk+" ,gtk+)
+ ("libdazzle" ,libdazzle)
+ ("libgdata" ,libgdata)
+ ("libgfbgraph" ,gfbgraph)
+ ("libjpeg" ,libjpeg-turbo)
+ ("libpng" ,libpng)
+ ("librest" ,rest)
+ ("pygobject" ,python-pygobject)
+ ("tracker" ,tracker)
+ ("tracker-miners" ,tracker-miners)))
+ (synopsis "Access, organize and share your photos on GNOME desktop")
+ (description "GNOME Photos is a simple and elegant replacement for using a
+file manager to deal with photos. Enhance, crop and edit in a snap. Seamless
+cloud integration is offered through GNOME Online Accounts.")
+ (home-page "https://wiki.gnome.org/Apps/Photos")
+ (license license:gpl3+)))
+
(define-public gnome-music
(package
(name "gnome-music")