summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-04-14 15:10:54 -0400
committerMark H Weaver <mhw@netris.org>2018-04-14 16:31:52 -0400
commitc97f2f70fe876030ab5e304d57fbc30033f86daa (patch)
tree7997e46b8c3d74d665c8da93aa480cd06a5042d7 /gnu/packages/gnome.scm
parent53e66fbceb275262184ad44f60a5a8d4e7061fcb (diff)
gnu: evolution-data-server: Fix build with ICU 61.
* gnu/packages/gnome.scm (evolution-data-server)[arguments]: In the configure flags, add "-DU_USING_ICU_NAMESPACE=1" to CMAKE_CXX_FLAGS.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 21e0f3d885..8861f26f71 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4907,8 +4907,12 @@ Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
"-DENABLE_GOOGLE_AUTH=OFF" ;disable Google authentication
"-DENABLE_VALA_BINDINGS=ON"
;; FIXME: Building against ICU 60 requires C++11 or higher. Remove
- ;; this when our default compiler is >= GCC6.
- "-DCMAKE_CXX_FLAGS=-std=gnu++11"
+ ;; "-std=gnu++11" when our default compiler is >= GCC6.
+ ;; FIXME: Temporarily use "-DU_USING_ICU_NAMESPACE=1" until
+ ;; evolution-data-server has been updated to qualify ICU types
+ ;; explicitly, as required by ICU 61 and later. See:
+ ;; <https://ssl.icu-project.org/repos/icu/trunk/icu4c/readme.html#RecBuild>
+ "-DCMAKE_CXX_FLAGS=-std=gnu++11 -DU_USING_ICU_NAMESPACE=1"
(string-append "-DCMAKE_INSTALL_RPATH=" lib ";"
(string-append lib "/evolution-data-server;")
(string-join runpaths ";"))