summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-05 00:36:55 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-07-15 09:58:50 -0400
commit11d28bd9f654f292b61c876e093e62a5ea242660 (patch)
treed77c5363bf6e6c7b59cd458a9f9d17a64f9c3406 /gnu/packages/gnome.scm
parentf828d05b28ed79c63c0eb521350506ad3b42cbf8 (diff)
gnu: devhelp: Update to 3.30.1.
* gnu/packages/gnome.scm (devhelp): Update to 3.30.1. [build-system]: Use meson-build-system. [native-inputs]: Add gobject-introspection, glib:bin and gtk+:bin. [inputs]: Add amtk.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 92ba991fc2..f9727ac477 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3409,7 +3409,7 @@ both a traditional UI or a modern UI with a GtkHeaderBar.")
(define-public devhelp
(package
(name "devhelp")
- (version "3.28.1")
+ (version "3.30.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -3417,14 +3417,18 @@ both a traditional UI or a modern UI with a GtkHeaderBar.")
name "-" version ".tar.xz"))
(sha256
(base32
- "08a8xizjqz68k30zd37r7g516azhan9bbrjsvv10hjd5dg3f476s"))))
- (build-system glib-or-gtk-build-system)
+ "036sddvhs0blqpc2ixmjdl9vxynvkn5jpgn0jxr1fxcm4rh3q07a"))))
+ (build-system meson-build-system)
(native-inputs
`(("intltool" ,intltool)
("itstool" ,itstool)
+ ("gobject-introspection" ,gobject-introspection)
+ ("glib:bin" ,glib "bin") ; for glib-mkmenus
+ ("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
("pkg-config" ,pkg-config)))
(inputs
- `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ `(("amtk" ,amtk)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("webkitgtk" ,webkitgtk)))
(home-page "https://wiki.gnome.org/Apps/Devhelp")
(synopsis "API documentation browser for GNOME")