summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-07-25 12:02:40 +0800
committer宋文武 <iyzsong@gmail.com>2015-07-26 09:52:45 +0800
commit41af5e7b7295a6133a7fb6c7a09e4bb26fb2b69f (patch)
tree0dc7e022268e9961bb9903422d391663bcd1c8ae /gnu/packages/gnome.scm
parentac5d70cdab81ca89420a68b067c6e7806bf14f6e (diff)
gnu: Add libgudev.
* gnu/packages/gnome.scm (libgudev): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 410a0f9083..115d508137 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3077,3 +3077,30 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
(description "Eye of GNOME is the GNOME image viewer. It
supports image conversion, rotation, and slideshows.")
(license license:gpl2+)))
+
+(define-public libgudev
+ (package
+ (name "libgudev")
+ (version "230")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "063w6j35n0i0ssmv58kivc1mw4070z6fzb83hi4xfrhcxnn7zrx2"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-genmarshal, etc.
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("glib" ,glib))) ; required by gudev-1.0.pc
+ (inputs
+ `(("udev" ,eudev)))
+ (home-page "https://wiki.gnome.org/Projects/libgudev")
+ (synopsis "GObject bindings for libudev")
+ (description
+ "This library provides GObject bindings for libudev. It was originally
+part of udev-extras, then udev, then systemd. It's now a project on its own.")
+ (license license:lgpl2.1+)))