summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-05-02 15:32:30 +0200
committerLudovic Courtès <ludo@gnu.org>2019-05-02 15:32:30 +0200
commit746ac457cc2748152a3a39d4296972fa20f19741 (patch)
tree978f3bdb71cfd062df8da9be7ae0218d214626e1 /gnu/packages/gnome.scm
parentc457f109bec75bfbf4619f3e18bcd82c33a15c07 (diff)
parent3a3e9f2bb586e79a7931163f0191df61591b8017 (diff)
Merge branch 'version-1.0.0'
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d33af15a29..8e3b7a406a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4633,6 +4633,14 @@ classes for commonly used data structures.")
(base32
"1qbcwq89g4r67k1dj4laqj441pj4195c8hzhxn8vc6mmg8adg6kx"))))
(build-system meson-build-system)
+ (arguments
+ ;; On 32-bit platforms, the test fails with a rounding error:
+ ;; <https://bugzilla.gnome.org/show_bug.cgi?id=775249>. Just skip it for
+ ;; now.
+ (if (and (not (%current-target-system))
+ (member (%current-system) '("i686-linux" "armhf-linux")))
+ '(#:tests? #f)
+ '()))
(native-inputs
`(("glib" ,glib "bin")
("pkg-config" ,pkg-config)))