summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-10-18 23:12:35 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-18 23:22:25 +0200
commite52b953434b255f53e61125c7fd3653adcebdab8 (patch)
tree1c1d8c5f2c4c7048496cfb10b8b0558cb22f0f1b /gnu/packages/gnome.scm
parent4e37cf35c0dc2c5be192f9a9455bfe4f23599e57 (diff)
services: network-manager: Create account for 'network-manager-openconnect'.
Previously, on startup, we'd see: dbus: Unknown username nm-openconnect in message bus configuration file This fixes it. * gnu/services/networking.scm (network-manager-accounts): New procedure. (network-manager-service-type): Extend 'account-service-type'. * gnu/packages/gnome.scm (network-manager-openconnect)[properties]: Add 'user-accounts'.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f17bd941cd..fafb93be08 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5635,7 +5635,12 @@ Compatible with Cisco VPN concentrators configured to use IPsec.")
to @acronym{VPNs, virtual private networks} via OpenConnect, an open client for
Cisco's AnyConnect SSL VPN.")
(license license:gpl2+)
- (properties `((upstream-name . "NetworkManager-openconnect")))))
+ (properties `((upstream-name . "NetworkManager-openconnect")
+
+ ;; The 'etc/dbus-1/system.d/nm-openconnect-service.conf'
+ ;; file refers to account "nm-openconnect". Specify it here
+ ;; so that 'network-manager-service-type' creates it.
+ (user-accounts . ("nm-openconnect"))))))
(define-public mobile-broadband-provider-info
(package