summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorJochem Raat <jchmrt@riseup.net>2016-02-13 23:14:29 +0100
committerDavid Thompson <dthompson2@worcester.edu>2016-02-13 21:09:42 -0500
commit3c697ffda34642f670dff51622274a17fd6963e7 (patch)
treeb87c001fc6447058cfb15a192419884379f0b366 /gnu/packages/gnome.scm
parentaa0edd3f5b2b596e8b8e8d16a9a61e9342223d12 (diff)
gnu: Add baobab.
* gnu/packages/gnome.scm (baobab): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 49e61973a0..fd0ce67c1e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
+;;; Copyright © 2016 Jochem Raat <jchmrt@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4648,3 +4649,35 @@ as SASL, TLS and VeNCrypt. Additionally it supports encoding extensions.")
design and behaviour, giving the user a simple way to navigate and manage its
files.")
(license license:gpl2+)))
+
+(define-public baobab
+ (package
+ (name "baobab")
+ (version "3.18.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1da4bdkw5bnxansl1xr4lb03d6f4h0a0qaba8i3p3rwhcd191b62"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("itstool" ,itstool)
+ ("xmllint" ,libxml2)
+ ("glib" ,glib "bin")
+ ("vala" ,vala)))
+ (inputs
+ `(("gtk+" ,gtk+)))
+ (synopsis "Disk usage analyzer for GNOME")
+ (description
+ "Baobab (Disk Usage Analyzer) is a graphical application to analyse disk
+usage in the GNOME desktop environment. It can easily scan device volumes or
+a specific user-requested directory branch (local or remote). Once the scan
+is complete it provides a graphical representation of each selected folder.")
+ (home-page "https://wiki.gnome.org/Apps/Baobab")
+ (license license:gpl2+)))