summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorAndy Wingo <wingo@igalia.com>2016-03-07 16:29:35 +0100
committerAndy Wingo <wingo@igalia.com>2016-03-07 21:14:23 +0100
commitb4f59d87a6c20de4bbf05af1ded1c09a2e2b240d (patch)
treec6a09bd70e1734431200dbd7b5d9b504bfcc5808 /gnu/packages/gnome.scm
parentc42602b5cb618f8fb8ce65af37c89b40a22f440c (diff)
gnu: network-manager: Disable failing tests.
* gnu/packages/gnome.scm (network-manager): Add pre-configure phase.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3a032a9c86..3c56304bda 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4195,6 +4195,19 @@ users.")
(string-append "--with-dhclient=" dhclient)))
#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'pre-configure
+ (lambda _
+ ;; These tests try to test aspects of network-manager's
+ ;; functionality within restricted containers, but they don't
+ ;; cope with being already in the Guix build jail as that jail
+ ;; lacks some features that they would like to proxy over (like
+ ;; a /sys mount).
+ (substitute* '("src/platform/Makefile.in")
+ (("SUBDIRS = tests") ""))
+ (substitute* '("src/tests/Makefile.in")
+ (("\ttest-route-manager-linux") "\t")
+ (("\ttest-route-manager-fake") "\t"))
+ #t))
(add-before 'check 'pre-check
(lambda _
;; For the missing /etc/machine-id.