summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-02-13 12:31:54 +0800
committer宋文武 <iyzsong@gmail.com>2016-02-17 20:57:55 +0800
commitdc0502516592446bccdd82ea1519d31e803de2f4 (patch)
tree363b96ddc9f895c0f42b84f354000b5408b14fd2 /gnu/packages/gnome.scm
parent7af1ca29f45e66c92e7f560af2eacce77a008298 (diff)
gnu: Add gnome.
* gnu/packages/gnome.scm (gnome): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fd0ce67c1e..e34ad83f9c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -37,6 +37,7 @@
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
@@ -4681,3 +4682,43 @@ a specific user-requested directory branch (local or remote). Once the scan
is complete it provides a graphical representation of each selected folder.")
(home-page "https://wiki.gnome.org/Apps/Baobab")
(license license:gpl2+)))
+
+(define-public gnome
+ (package
+ (name "gnome")
+ (version (package-version gnome-shell))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments '(#:builder (mkdir %output)))
+ (propagated-inputs
+ ;; TODO: Add more packages according to:
+ ;; <https://packages.debian.org/jessie/gnome-core>.
+ `(("adwaita-icon-theme" ,adwaita-icon-theme)
+ ("at-spi2-core" ,at-spi2-core)
+ ("dbus" ,dbus)
+ ("dconf" ,dconf)
+ ("eog" ,eog)
+ ("epiphany" ,epiphany)
+ ("evince" ,evince)
+ ("gedit" ,gedit)
+ ("glib-networking" ,glib-networking)
+ ("gnome-control-center" ,gnome-control-center)
+ ("gnome-keyring" ,gnome-keyring)
+ ("gnome-session" ,gnome-session)
+ ("gnome-settings-daemon" ,gnome-settings-daemon)
+ ("gnome-shell" ,gnome-shell)
+ ("gnome-terminal" ,gnome-terminal)
+ ("gnome-themes-standard" ,gnome-themes-standard)
+ ("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("nautilus" ,nautilus)
+ ("pulseaudio" ,pulseaudio)
+ ("shared-mime-info" ,shared-mime-info)
+ ("totem" ,totem)
+ ("yelp" ,yelp)
+ ("zenity" ,zenity)))
+ (synopsis "Desktop environment (meta-package)")
+ (home-page "https://www.gnome.org/")
+ (description
+ "GNOME is an intutive and attractive desktop environment. It aims to be
+an easy and elegant way to use your computer.")
+ (license license:gpl2+)))