summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-08-14 18:10:10 +0800
committerMark H Weaver <mhw@netris.org>2015-08-14 17:58:48 -0400
commit907f939b9bc43202519e2d6607013da06323f362 (patch)
treea1a7f312b15dd33e82cbb06065bafbf59df30709 /gnu/packages/gnome.scm
parent6c591c8ed729ea2f253a5337d35343a527c82e74 (diff)
gnu: glib-networking: Prefer 'SSL_CERT_FILE' as TLS CA file.
This is an improvement over commit af6100f. * gnu/packages/gnome.scm (glib-networking)[source](patches): New field. [arguments]: Pass '/etc/ssl/certs/ca-certificates.crt' to configure. Set 'SSL_CERT_FILE' to '/dev/null' in 'use-empty-ssl-cert-file' phase. (libsoup)[arguments]: Set 'SSL_CERT_FILE' to '/dev/null' in 'pre-check' phase. * gnu/packages/patches/glib-networking-ssl-cert-file.patch: New patch. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm24
1 files changed, 17 insertions, 7 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e510eb55ac..80c13dccb0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1872,12 +1872,13 @@ library.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0ij33bhvn7y5gagx4sbrw906dsjjjs9dllxn73pzv6x97c6k92lg"))))
+ "0ij33bhvn7y5gagx4sbrw906dsjjjs9dllxn73pzv6x97c6k92lg"))
+ (patches
+ (list (search-patch "glib-networking-ssl-cert-file.patch")))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
- ;; FIXME: ca-certificates.crt is not available in the build environment.
- '("--with-ca-certificates=no")
+ '("--with-ca-certificates=/etc/ssl/certs/ca-certificates.crt")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-giomoduledir
@@ -1886,7 +1887,13 @@ library.")
(substitute* "configure"
(("GIO_MODULE_DIR=.*")
(string-append "GIO_MODULE_DIR=" %output
- "/lib/gio/modules\n"))))))))
+ "/lib/gio/modules\n")))))
+ (add-before 'check 'use-empty-ssl-cert-file
+ (lambda _
+ ;; The ca-certificates.crt is not available in the build
+ ;; environment.
+ (setenv "SSL_CERT_FILE" "/dev/null")
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))
@@ -1968,11 +1975,14 @@ libxml to ease remote use of the RESTful API.")
(substitute* "tests/socket-test.c"
((".*/sockets/unconnected.*") ""))
#t))
- (add-before 'check 'unset-LC_ALL
- ;; The 'check-local' target runs 'env LANG=C sort -u',
- ;; unset 'LC_ALL' to make 'LANG' working.
+ (add-before 'check 'pre-check
(lambda _
+ ;; The 'check-local' target runs 'env LANG=C sort -u',
+ ;; unset 'LC_ALL' to make 'LANG' working.
(unsetenv "LC_ALL")
+ ;; The ca-certificates.crt is not available in the build
+ ;; environment.
+ (setenv "SSL_CERT_FILE" "/dev/null")
#t)))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums