summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRene Saavedra <rennes@openmailbox.org>2016-10-20 20:30:40 -0500
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-23 19:26:30 +0200
commit04ce840a82a82fdae93cede4b678a66c88ee5312 (patch)
treecc77228d3684f35d748d53d49e724595349814d6 /gnu/packages/gnome.scm
parentb5c347ad3d83ee580c111bd14c80b469b0dcb294 (diff)
gnu: Add bluefish.
* gnu/packages/gnome.scm (bluefish): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b7dcd01a11..5f4fc8275f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5605,3 +5605,34 @@ characters and categories for the installed fonts, and to examine their
detailed properties. It is an easy way to find the character you might
only know by its Unicode name or code point.")
(license license:gpl3+)))
+
+(define-public bluefish
+ (package
+ (name "bluefish")
+ (version "2.2.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.bennewitz.com/bluefish/stable/source/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vnl6raxbvc4hacg3pr6sqyjh707d304dhk5nyhlp7m0m1y3j756"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("enchant" ,enchant)
+ ("gtk+" ,gtk+)
+ ("python" ,python-2)
+ ("xmllint" ,libxml2)
+ ("gucharmap" ,gucharmap)))
+ (home-page "http://bluefish.openoffice.nl")
+ (synopsis "Web development studio")
+ (description
+ "Bluefish is an editor targeted towards programmers and web developers,
+with many options to write web sites, scripts and other code.
+Bluefish supports many programming and markup languages.")
+ (license license:gpl3+)))