summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-10-20 22:17:07 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-20 22:18:59 +0200
commit29d2f451a663ecf48b9a0709edea2ae2a4124f4d (patch)
treee55a61b7e54855e1acfc59bced6e08735b744002 /gnu/packages/gnome.scm
parent0d871c38766874995c199adc808b97c00394e15d (diff)
gnu-maintenance: GNOME updater honors 'upstream-name' package property.
* guix/gnu-maintenance.scm (latest-gnome-release)[upstream-name]: New variable. Use it as the first argument to 'latest-ftp-release' and when constructing #:directory. * gnu/packages/gnome.scm (gconf)[properties]: New field. (network-manager)[properties]: New field.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9e41f3a65e..dd8305144b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1130,7 +1130,8 @@ use in GNOME applications, built on top of CORBA.")
(synopsis "Store application preferences")
(description "Gconf is a system for storing application preferences. It
is intended for user preferences; not arbitrary data storage.")
- (license license:lgpl2.0+)))
+ (license license:lgpl2.0+)
+ (properties '((upstream-name . "GConf")))))
(define-public gnome-mime-data
@@ -4481,7 +4482,8 @@ devices and connections, attempting to keep active network connectivity when
available. It manages ethernet, WiFi, mobile broadband (WWAN), and PPPoE
devices, and provides VPN integration with a variety of different VPN
services.")
- (license license:gpl2+)))
+ (license license:gpl2+)
+ (properties '((upstream-name . "NetworkManager")))))
(define-public mobile-broadband-provider-info
(package