summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-11-13 17:48:11 +0800
committer宋文武 <iyzsong@gmail.com>2015-11-13 17:59:50 +0800
commit2af4f5b051702551afd95079cdb0c2e51a902777 (patch)
treec844f8e308410a092de5d7d7a647fd193390ff6b /gnu/packages/gnome.scm
parent9083788a294e5ccbbd9bd4b2bb2867dae7079018 (diff)
gnu: gcr: Update to 3.18.0, enable introspection.
* gnu/packages/gnome.scm (gcr): Update to 3.18.0. [native-inputs]: Add gobject-introspection and libxslt.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8869b62629..f51532fdd8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -247,7 +247,7 @@ and keep up to date translations of documentation.")
(define-public gcr
(package
(name "gcr")
- (version "3.16.0")
+ (version "3.18.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -255,7 +255,7 @@ and keep up to date translations of documentation.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0xfhi0w358lvca1jjx24x2gm67mif33dsnmi9cv5i0f83ks8vzpc"))))
+ "006f6xbd3jppkf9avg83mpqdld5d0z6mr0sm81lql52mmyjnvlfl"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ;25 of 598 tests fail because /var/lib/dbus/machine-id does
@@ -274,7 +274,9 @@ and keep up to date translations of documentation.")
`(("python" ,python-2) ;for tests
("pkg-config" ,pkg-config)
("glib" ,glib "bin")
- ("intltool" ,intltool)))
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("xsltproc" ,libxslt)))
;; mentioned in gck.pc, gcr.pc and gcr-ui.pc
(propagated-inputs
`(("p11-kit" ,p11-kit)