summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRene Saavedra <rennes@openmailbox.org>2016-10-09 14:57:25 -0500
committerLudovic Courtès <ludo@gnu.org>2016-10-19 23:20:19 +0200
commit3ad7dce1d97676d9ec948fb46ccd8c53f307d04d (patch)
tree840e8dd8d51ac63494f5e8bb597f1f8f431e14af /gnu/packages/gnome.scm
parent80c9164fd7741e3bb3da368666f41c49a456d990 (diff)
gnu: Add gucharmap.
* gnu/packages/gnome.scm (gucharmap): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 52d6cd4c82..b7dcd01a11 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5572,3 +5572,36 @@ is suitable as a default application in a Desktop environment.")
and customizable. Xpad consists of independent pad windows, each is
basically a text box in which notes can be written.")
(license license:gpl3+)))
+
+(define-public gucharmap
+ (package
+ (name "gucharmap")
+ (version "3.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0c1q9w5vql0vvg6g0knxfnv4ap19fg5cdrwndi1cj9lsym92c78j"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("glib:bin" ,glib "bin") ; for glib-compile-resources.
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("xmllint" ,libxml2)))
+ (home-page "https://wiki.gnome.org/Apps/Gucharmap")
+ (synopsis "Unicode character picker and font browser")
+ (description
+ "This program allows you to browse through all the available Unicode
+characters and categories for the installed fonts, and to examine their
+detailed properties. It is an easy way to find the character you might
+only know by its Unicode name or code point.")
+ (license license:gpl3+)))