summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-07-26 22:08:44 +0800
committer宋文武 <iyzsong@gmail.com>2015-07-27 21:24:51 +0800
commit3dc8828f18d61e307d9482f9c3d4020b0457d7d1 (patch)
tree879037b54f821b766c343aa73bb651e5aee07389 /gnu/packages/gnome.scm
parentcff77d4897e4dea882ee2c6379d85f66a465b8a9 (diff)
gnu: Add GVFS.
* gnu/packages/gnome.scm (gvfs): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0feb5b480e..fb5c67e396 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -83,6 +83,9 @@
#:use-module (gnu packages backup)
#:use-module (gnu packages nettle)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages cdrom)
+ #:use-module (gnu packages samba)
#:use-module (srfi srfi-1))
(define-public brasero
@@ -3107,3 +3110,55 @@ supports image conversion, rotation, and slideshows.")
"This library provides GObject bindings for libudev. It was originally
part of udev-extras, then udev, then systemd. It's now a project on its own.")
(license license:lgpl2.1+)))
+
+(define-public gvfs
+ (package
+ (name "gvfs")
+ (version "1.24.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1ygiknnd24qgzds8wif3jns981mqr65lgjlxs5pw65cl3376g0yk"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f)) ; XXX: requiring `pidof'
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-genmarshal, etc.
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("xsltproc" ,libxslt)))
+ (inputs
+ `(("avahi" ,avahi)
+ ("docbook-xml" ,docbook-xml-4.2)
+ ("docbook-xsl" ,docbook-xsl)
+ ("dbus" ,dbus)
+ ("fuse" ,fuse)
+ ("glib" ,glib)
+ ("libarchive" ,libarchive)
+ ("libbluray" ,libbluray)
+ ("libcdio-paranoia" ,libcdio-paranoia)
+ ("libgcrypt" ,libgcrypt)
+ ("libgphoto2" ,libgphoto2)
+ ("libgudev" ,libgudev)
+ ("libmtp" ,libmtp)
+ ("libsecret" ,libsecret)
+ ("libsmbclient" ,samba)
+ ("libsoup" ,libsoup)
+ ("libxml2" ,libxml2)
+ ("nettle" ,nettle) ; XXX: required by libarchive.pc
+ ("udisks" ,udisks)))
+ (home-page "https://wiki.gnome.org/gvfs/")
+ (synopsis "Userspace virtual filesystem for GIO")
+ (description
+ "GVFS is a userspace virtual filesystem designed to work with the I/O
+abstraction of GIO. It contains a GIO module that seamlessly adds GVFS support
+to all applications using the GIO API. It also supports exposing the GVFS
+mounts to non-GIO applications using FUSE.
+
+GVFS comes with a set of backends, including trash support, SFTP, SMB, HTTP,
+DAV, and others.")
+ (license license:lgpl2.0+)))