summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-04-06 21:43:16 +0800
committerLudovic Courtès <ludo@gnu.org>2016-04-16 11:46:50 +0200
commitb384bfcfa43fc0b1677c03ca26fd73f54663ec6c (patch)
treebfaf4ac2497dcbda21a856f363a6e34580f618ba /gnu/packages/gnome.scm
parent884bb4ef248174d3e0f7f26cf71c6ddac92b5327 (diff)
gnu: vte: Update to 0.44.0.
* gnu/packages/gnome.scm (vte): Update to 0.44.0. [arguments]: New field.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 042d7a27da..4b96847af5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1724,7 +1724,7 @@ libraries written in C.")
(define-public vte
(package
(name "vte")
- (version "0.42.3")
+ (version "0.44.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1732,8 +1732,16 @@ libraries written in C.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1832mrw2hhgjipbsfsv2fmdnwnar4rkx589ciz008bg8x908mscn"))))
+ "1ahjxysiv38q91gfq2wddcbvndlggfr8ynls25m42pw83akv38wk"))))
(build-system gnu-build-system)
+ (arguments
+ ;; XXX: fails to compile tests with the default flags.
+ ;; vteconv.cc:774:40:
+ ;; error: missing sentinel in function call [-Werror=format=]
+ ;; g_test_init (&argc, &argv, NULL);
+ ;;
+ ;; cc1plus: some warnings being treated as errors
+ '(#:configure-flags '("CXXFLAGS=-Wformat=0")))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)