summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-01-09 18:32:00 -0500
committerMark H Weaver <mhw@netris.org>2017-01-11 11:34:52 -0500
commitdc69fe187b287fb3956da4fe7d5509632c90ef1f (patch)
tree5b3c24ab83f56fb6ea1ffe063c57a4520ecbb8b7 /gnu/packages/gnome.scm
parenta88d5a0c25cb6197f1159e196e56c36e8e5db11f (diff)
gnu: Add gnome-autoar.
* gnu/packages/gnome.scm (gnome-autoar): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index af843f55ca..aa3a1bc08b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4973,6 +4973,35 @@ GTK-VNC implements client side RFB protocol and authentication extensions such
as SASL, TLS and VeNCrypt. Additionally it supports encoding extensions.")
(license license:lgpl2.1+)))
+(define-public gnome-autoar
+ (package
+ (name "gnome-autoar")
+ (version "0.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1jcs6jgysg9n3zi3d1l4iqddzmczfdcvz7vkxn607p32nl8bhp7n"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("gnome-common" ,gnome-common)
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("libarchive" ,libarchive))) ; XXX document why
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("nettle" ,nettle))) ; XXX: required by libarchive.pc
+ (synopsis "Archives integration support for GNOME")
+ (home-page "https://git.gnome.org/browse/gnome-autoar/")
+ (description
+ "GNOME Autoar is a library which makes creating and extracting archives
+easy, safe, and automatic.")
+ (license license:lgpl2.1+)))
+
(define-public nautilus
(package
(name "nautilus")