summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-04-28 10:04:52 +0800
committer宋文武 <iyzsong@gmail.com>2016-05-02 22:06:43 +0800
commit803ab4164da2f464714e4199342380d1960445fc (patch)
treeef40c333a8cebb5fcb29569debc3a694d8eede7d /gnu/packages/gnome.scm
parent74cf8f6cf92387272c452102f862809160cda8aa (diff)
gnu: gnome-session: Update to 3.20.1, fix build.
* gnu/packages/gnome.scm (gnome-session): Update to 3.20.1. [arguments]: Remove use of systemd in 'gsm-autostart-app.c.'.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6941a901a5..54984f1a32 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3819,7 +3819,7 @@ such as gzip tarballs.")
(define-public gnome-session
(package
(name "gnome-session")
- (version "3.20.0")
+ (version "3.20.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -3827,7 +3827,7 @@ such as gzip tarballs.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0d0v60lmvr8wbrswfpc4f4jg2dhxj6nkgv7wnwdf2zifk8vp5zv6"))))
+ "04w90gyl0kdx5vwmdcgfdk3qr9xhip00vgpgzci151agqwyzbs9a"))))
(arguments
'(#:phases
(modify-phases %standard-phases
@@ -3846,6 +3846,8 @@ such as gzip tarballs.")
(("#ifdef HAVE_SYSTEMD") "#if 0"))
(substitute* "gnome-session/gsm-manager.c"
(("#ifdef HAVE_SYSTEMD") "#if 0"))
+ (substitute* "gnome-session/gsm-autostart-app.c"
+ (("#ifdef HAVE_SYSTEMD") "#if 0"))
#t))
(add-after 'install 'wrap-gnome-session
(lambda* (#:key inputs outputs #:allow-other-keys)