summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-21 22:36:30 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-22 00:26:10 -0500
commit201fb6c63b488c09a1e4ec5537adfa13a174d005 (patch)
tree933743d82ff162410f3d6433b779a4067c9f8c10 /gnu/packages/gnome.scm
parentd10c8f5ef1c2c7231d26202d4f432b48c9bc3611 (diff)
gnu: cheese: Wrap GST_PRESET_PATH to find GstVP8Enc.prs.
Before this fix, cheese would complain like so: (cheese:15094): cheese-WARNING **: Can't find vp8enc preset: "Profile Realtime", using alternate preset: "Cheese Realtime". If you see this, make a bug report! If you've run cheese before, make sure to run "rm -rf ~/.local/share/gstreamer-1.0" to make the fix effective. * gnu/packages/gnome.scm (cheese) [phases]: Set the GST_PRESET_PATH environment variable in the wrap phase.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6e89d43bec..5d4c0fe92c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11460,10 +11460,14 @@ photo-booth-like software, such as Cheese.")
(substitute* "meson_post_install.py"
(("gtk-update-icon-cache") (which "true")))))
(add-after 'install 'wrap-cheese
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (search-input-file outputs "bin/cheese")
- `("GST_PLUGIN_SYSTEM_PATH" ":" prefix
- (,(getenv "GST_PLUGIN_SYSTEM_PATH")))))))))
+ `("GST_PLUGIN_SYSTEM_PATH" prefix
+ (,(getenv "GST_PLUGIN_SYSTEM_PATH")))
+ `("GST_PRESET_PATH" prefix
+ (,(dirname (search-input-file inputs
+ "share/gstreamer-1.0\
+/presets/GstVP8Enc.prs"))))))))))
(build-system meson-build-system)
(native-inputs
(list docbook-xml-4.3