summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2024-01-14 13:11:03 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-03 08:29:03 +0100
commit3aef72ec5bf1027bc557daab7010848d80711a28 (patch)
tree46718f34d51f918a0ff1c083fd803e390f27f48e /gnu/packages/gnome.scm
parentf5f345153ce02f3c1e5db9d77d8337de648d2540 (diff)
gnu: deja-dup: update to 45.2.
* gnu/packages/gnome.scm (deja-dup): Update to 45.2. [arguments]: Convert to list of G-Expressions. Change-Id: I60823287827b0690796fec7955bcf9682acd88b3 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm73
1 files changed, 37 insertions, 36 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3d89f06d6a..75e2e0efb8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1823,50 +1823,51 @@ configuration files for the GNOME menu, as well as a simple menu editor.")
(define-public deja-dup
(package
(name "deja-dup")
- (version "43.4")
+ (version "45.2")
(source (origin
(method url-fetch)
(uri (string-append "https://gitlab.gnome.org/World/deja-dup/-/archive/"
version "/deja-dup-" version ".tar.bz2"))
(sha256
(base32
- "1mr2g009w0zm5rj8dg1k77c7zdwylih2yszm8vh8wkw6al6bzfh3"))))
+ "000cwy1haiglkvn5plmhrs2a1fhpcpw6z4mdzck7ybmky795amza"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
- #:configure-flags
- (list
- ;; Otherwise, the RUNPATH will lack the final path component.
- (string-append "-Dc_link_args=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib/deja-dup"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((python (assoc-ref inputs "python")))
- (substitute* '("libdeja/duplicity/DuplicityInstance.vala"
- "libdeja/tests/scripts/instance-error.test")
- (("/bin/rm")
- (which "rm")))
- (substitute* "libdeja/tests/runner.vala"
- (("/bin/sh")
- (which "sh")))
- (substitute* "libdeja/tests/scripts/instance-error.test"
- (("`which python3`")
- (string-append python "/bin/python3"))))))
- (add-after 'unpack 'patch-libgpg-error
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((libgpg-error (assoc-ref inputs "libgpg-error")))
- (substitute* "meson.build"
- (("(gpgerror_libs = ).*" _ var)
- (format #f "~a '-L~a/lib -lgpg-error'\n" var libgpg-error))))))
- (add-after 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Add duplicity to the search path
- (wrap-program (string-append (assoc-ref outputs "out")
- "/bin/deja-dup")
- `("PATH" ":" prefix
- (,(string-append (assoc-ref inputs "duplicity") "/bin")))))))))
+ (list
+ #:glib-or-gtk? #t
+ #:configure-flags
+ #~(list
+ ;; Otherwise, the RUNPATH will lack the final path component.
+ (string-append "-Dc_link_args=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib/deja-dup"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((python (assoc-ref inputs "python")))
+ (substitute* '("libdeja/duplicity/DuplicityInstance.vala"
+ "libdeja/tests/scripts/instance-error.test")
+ (("/bin/rm")
+ (which "rm")))
+ (substitute* "libdeja/tests/runner.vala"
+ (("/bin/sh")
+ (which "sh")))
+ (substitute* "libdeja/tests/scripts/instance-error.test"
+ (("`which python3`")
+ (string-append python "/bin/python3"))))))
+ (add-after 'unpack 'patch-libgpg-error
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libgpg-error (assoc-ref inputs "libgpg-error")))
+ (substitute* "meson.build"
+ (("(gpgerror_libs = ).*" _ var)
+ (format #f "~a '-L~a/lib -lgpg-error'\n" var libgpg-error))))))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Add duplicity to the search path
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/deja-dup")
+ `("PATH" ":" prefix
+ (,(dirname (search-input-file inputs "/bin/duplicity"))))))))))
(inputs
(list bash-minimal
duplicity