summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-06-17 01:38:47 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-06-25 14:27:59 +0200
commit5abcfe7a795467f4cbfc0a3f142e2a7156374d67 (patch)
tree3a1d98abc9d1e1dfbf7e3eec4974d7f9ee4c188d /gnu/packages/gnome.scm
parentbf164e8d3796b76f71b62217f5ac295646909a76 (diff)
gnu: cambalache: Update to 0.12.0.
* gnu/packages/gnome.scm (cambalache): Update to 0.12.0. [arguments]<#:tests?>: Disable. <#:phases>: Adjust ‘patch-build’ accordingly. Add ‘fake-cc’. [inputs]: Add gtksourceview-4 and python-pycairo. Replace webkitgtk-with-libsoup2 with webkitgtk and webkitgtk-next. [native-inputs]: Add weston.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm29
1 files changed, 23 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 24ed87df80..d4dd54e5d7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3303,7 +3303,7 @@ compiles to GTKBuilder XML.")
(define-public cambalache
(package
(name "cambalache")
- (version "0.10.3")
+ (version "0.12.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3311,7 +3311,7 @@ compiles to GTKBuilder XML.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1nq9bvly4dm1xnh90z3b4c5455qpdgm3jgz2155vg2ai23f22vsy"))))
+ (base32 "12dhc7mx04cpc9qwcvqiplphh3mar7wy6cbkv208j7pcg5fzkqh0"))))
(build-system meson-build-system)
(arguments
(list
@@ -3321,6 +3321,7 @@ compiles to GTKBuilder XML.")
#:modules '((guix build meson-build-system)
((guix build python-build-system) #:prefix python:)
(guix build utils))
+ #:tests? #f ; XXX: tests spawn a socket...
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -3331,8 +3332,16 @@ compiles to GTKBuilder XML.")
inputs (string-append "bin/" cmd)))))))
(add-after 'unpack 'patch-build
(lambda _
+ (substitute* "meson.build"
+ (("find_program\\('gtk-update-icon-cache'.*\\)") "")
+ (("find_program\\('update-desktop-database'.*\\)") ""))
(substitute* "postinstall.py"
+ (("gtk-update-icon-cache") "true")
(("update-desktop-database") "true"))))
+ (add-after 'unpack 'fake-cc
+ (lambda _
+ (substitute* "tools/cmb_init_dev.py"
+ (("\"cc") (string-append "\"" #$(cc-for-target))))))
(add-after 'wrap 'python-wrap (assoc-ref python:%standard-phases 'wrap))
(delete 'check)
(add-after 'install 'add-install-to-pythonpath
@@ -3372,18 +3381,26 @@ compiles to GTKBuilder XML.")
adwaita-icon-theme hicolor-icon-theme
gsettings-desktop-schemas
gtk
+ gtksourceview-4
`(,gtk+ "bin") ; broadwayd
`(,gtk "bin")
libadwaita
libhandy
(librsvg-for-system)
python
+ python-pycairo
python-pygobject
python-lxml
- webkitgtk-with-libsoup2))
- (native-inputs (list `(,glib "bin") gobject-introspection
- gettext-minimal pkg-config
- python-pytest xorg-server-for-tests))
+ webkitgtk
+ webkitgtk-next))
+ (native-inputs
+ (list `(,glib "bin")
+ gobject-introspection
+ gettext-minimal
+ pkg-config
+ python-pytest
+ weston
+ xorg-server-for-tests))
(home-page "https://gitlab.gnome.org/jpu/cambalache")
(synopsis "Rapid application development tool")
(description "Cambalache is a rapid application development (RAD) tool for