summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-12-25 16:17:27 +0100
committerMathieu Othacehe <othacehe@gnu.org>2023-12-27 21:58:29 +0100
commit931d893c550128591018587c90d2491fd66a11a4 (patch)
tree397e04e5ddfdaf6befe25108eb7d3dbd4e41ce7a /gnu/packages/gnome.scm
parent0a55bf68bb6af5e3f239230dec802011a0f42607 (diff)
gnu: gthumb: Improve style.
* gnu/packages/gnome.scm (gthumb): [arguments]: Use gexp. [native-inputs]: Rewrite using list. [inputs]: Rewrite using list. Change-Id: I925c3ac0ebef89534608926545309ff232e2af01 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm60
1 files changed, 29 insertions, 31 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 89a1c45883..b2d4b73088 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11812,38 +11812,36 @@ functionality.")
"09flm8s6jrvfya2ypw5873mnnani8ssy7wdv3ra1cljk4bjszy4p"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
- #:configure-flags
- ;; Ensure the RUNPATH contains all installed library locations.
- (list (string-append "-Dc_link_args=-Wl,-rpath="
- (assoc-ref %outputs "out")
- "/lib/gthumb/extensions")
- (string-append "-Dcpp_link_args=-Wl,-rpath="
- (assoc-ref %outputs "out")
- "/lib/gthumb/extensions"))))
- (native-inputs
- `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
- ("glib:bin" ,glib "bin") ; for glib-compile-resources
- ("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
- ("intltool" ,intltool)
- ("itstool" ,itstool)
- ("pkg-config" ,pkg-config)
- ("python" ,python)))
+ (list
+ #:glib-or-gtk? #t
+ #:configure-flags
+ ;; Ensure the RUNPATH contains all installed library locations.
+ #~(list (string-append "-Dc_link_args=-Wl,-rpath=" #$output
+ "/lib/gthumb/extensions")
+ (string-append "-Dcpp_link_args=-Wl,-rpath=" #$output
+ "/lib/gthumb/extensions"))))
+ (native-inputs
+ (list desktop-file-utils ; for update-desktop-database
+ `(,glib "bin") ; for glib-compile-resources
+ `(,gtk+ "bin") ; for gtk-update-icon-cache
+ intltool
+ itstool
+ pkg-config
+ python))
(inputs
- `(("clutter" ,clutter)
- ("clutter-gst" ,clutter-gst)
- ("clutter-gtk" ,clutter-gtk)
- ("colord" ,colord)
- ("exiv2" ,exiv2)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("gstreamer" ,gstreamer)
- ("gtk" ,gtk+)
- ("libheif" ,libheif)
- ("libjpeg" ,libjpeg-turbo)
- ("libraw" ,libraw)
- ("librsvg" ,(librsvg-for-system))
- ("libtiff" ,libtiff)
- ("libwebp" ,libwebp)))
+ (list clutter
+ clutter-gst
+ clutter-gtk
+ colord
+ exiv2
+ gsettings-desktop-schemas
+ gtk+
+ libheif
+ libjpeg-turbo
+ libraw
+ (librsvg-for-system)
+ libtiff
+ libwebp))
(home-page "https://wiki.gnome.org/Apps/Gthumb")
(synopsis "GNOME image viewer and browser")
(description "GThumb is an image viewer, browser, organizer, editor and