summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-07-30 01:01:33 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-07-30 01:05:41 -0400
commitd1804ebfc927f5a34f2ad7957dac1aa4c2e2107f (patch)
tree94e4332c6a92ba3c5f68a7d21ee712fd2724101f /gnu/packages/gnome.scm
parent4f0ce65b74a3d28bf6ecbe4c15052dd0de22b284 (diff)
gnu: mutter: Fix build.
With newer versions of Mesa, a test in ensure_bits_initialized fails. Fixed upstream in newer versions of mutter. See <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3047>. * gnu/packages/gnome.scm (mutter)[source]: Add patch. * gnu/packages/patches/mutter-fix-inverted-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b09d9b4afd..b576f466b7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7817,7 +7817,10 @@ to display dialog boxes from the commandline and shell scripts.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0h1ak3201mdc2qbf67fhcn801ddp33hm0f0c52zis1l7s6ipyb62"))))
+ "0h1ak3201mdc2qbf67fhcn801ddp33hm0f0c52zis1l7s6ipyb62"))
+ ;; TODO: Remove on update as this was merged upstream. See
+ ;; <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3047>.
+ (patches (search-patches "mutter-fix-inverted-test.patch"))))
;; NOTE: Since version 3.21.x, mutter now bundles and exports forked
;; versions of cogl and clutter. As a result, many of the inputs,
;; propagated-inputs, and configure flags used in cogl and clutter are