summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-09 10:42:45 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-09 12:51:34 -0400
commit8edec9060f8dba97d954d1634035f5bb8582b632 (patch)
tree37dd6f478d3966b3b556cdfdd228c4bcd849cacc /gnu/packages/gnome.scm
parente1e95fda231aa2cd8e22cc45222a70db14af9c5f (diff)
gnu: dconf-editor: Update to 43.0.
* gnu/packages/gnome.scm (dconf-editor): Update to 43.0. [source]: Update source URL. [arguments]: Remove #:meson, add #:phases. [native-inputs]: Remove labels. [inputs]: Add libhandy.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm39
1 files changed, 22 insertions, 17 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6d67d8fcbe..006fd0faae 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9914,27 +9914,32 @@ beautifying border effects.")
(define-public dconf-editor
(package
(name "dconf-editor")
- (version "3.38.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1qvrxrk1h8bd75xwasxbvlkqrw6xkavjimvc7sslkw6lvb3z86jp"))))
+ (version "43.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0dli166qzfphqlyvdx4nncg13ys7756sbsdfslyakhkcswnkqnlk"))))
(build-system meson-build-system)
(arguments
- (list #:meson meson-0.60))
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-gtk-update-icon-cache
+ (lambda _
+ (setenv "DESTDIR" "/"))))))
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-compile-schemas, gio-2.0.
- ("gtk+-bin" ,gtk+ "bin") ; for gtk-update-icon-cache
- ("intltool" ,intltool)
- ("pkg-config" ,pkg-config)
- ("vala" ,vala)))
+ (list `(,glib "bin") ;for glib-compile-schemas, gio-2.0
+ `(,gtk "bin") ;for gtk-update-icon-cache
+ intltool
+ pkg-config
+ vala))
(inputs
- (list dconf gtk+ libxml2))
+ (list dconf
+ gtk+
+ libhandy
+ libxml2))
(home-page "https://gitlab.gnome.org/GNOME/dconf-editor")
(synopsis "Graphical editor for GNOME's dconf configuration system")
(description