summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-16 00:31:21 +0200
committerMarius Bakke <marius@gnu.org>2022-09-18 16:18:35 +0200
commit94827144d18056713c908dbfde6c399c48e9634a (patch)
tree424fc6f967e68266f804b51f4642dfc39d180adc /gnu/packages/gnome.scm
parent2104efcddfd7649839673886ec44f77dcd5b5041 (diff)
gnu: gnome-settings-daemon: Add NSS on RUNPATH.
* gnu/packages/gnome.scm (gnome-settings-daemon)[arguments]: Ensure NSS ends up on RUNPATH.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c7e5115802..c8a49040f4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5886,7 +5886,10 @@ services for numerous locations.")
"-Dsystemd=false"
;; Otherwise, the RUNPATH will lack the final path component.
(string-append "-Dc_link_args=-Wl,-rpath=" #$output
- "/lib/gnome-settings-daemon-3.0"))
+ "/lib/gnome-settings-daemon-3.0:"
+ ;; Also add NSS because for some reason Meson
+ ;; > 0.60 does not add it automatically (XXX).
+ (search-input-directory %build-inputs "lib/nss")))
#:phases
#~(modify-phases %standard-phases
(add-before 'configure 'set-baobab-file-name