summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorAdam Faiz <adam.faiz@disroot.org>2023-02-20 21:50:30 +0800
committerGuillaume Le Vaillant <glv@posteo.net>2023-02-22 17:04:14 +0100
commit454c9731973d15a22967cfd815134ee5d251c053 (patch)
treebf7e655ff87de1b1be65fda307f36153a3959dd5 /gnu/packages/gnunet.scm
parent5ef168dfb7ea4217b5637d0cdd2ff7627fd3d74f (diff)
gnu: gnunet-gtk: Use new style inputs and gexps.
* gnu/packages/gnunet.scm (gnunet-gtk)[arguments]: Use new style and gexps. [inputs]: Use new style. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 1fe8e95086..3ed18fbdb5 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -446,21 +446,21 @@ The following services are supported:
(base32
"0z2731l69vnfsa0cdsw8wh8g1d08wz15y5n0a58qjpf7baric01k"))))
(arguments
- `(#:configure-flags
- (list "--with-libunique"
- "--with-qrencode"
- (string-append "--with-gnunet="
- (assoc-ref %build-inputs "gnunet")))))
+ (list #:configure-flags
+ #~(list "--with-libunique"
+ "--with-qrencode"
+ (string-append "--with-gnunet="
+ #$(this-package-input "gnunet")))))
(inputs
- `(("glade3" ,glade3)
- ("gnunet" ,gnunet)
- ("gnutls" ,gnutls/dane)
- ("gtk+" ,gtk+)
- ("libextractor" ,libextractor)
- ("libgcrypt" ,libgcrypt)
- ("libsodium" ,libsodium)
- ("libunique" ,libunique)
- ("qrencode" ,qrencode)))
+ (list glade3
+ gnunet
+ gnutls/dane
+ gtk+
+ libextractor
+ libgcrypt
+ libsodium
+ libunique
+ qrencode))
(native-inputs
(list pkg-config libglade))
(synopsis "Graphical front-end tools for GNUnet")