summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-31 11:48:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-31 13:29:28 -0400
commitee0de79b1efcd991fa7d3586423e1b5cdcaf993c (patch)
tree079d63b39af7235a156b740e5cdf7bf2c067e79d /gnu/packages/gnunet.scm
parent2d4b61d014ce6daba6bc6c39df77a0c46cffe55c (diff)
gnu: gnunet: Disable flaky tests.
* gnu/packages/gnunet.scm (gnunet) [arguments]: Add a disable-problematic-tests phase.
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 2b494862ad..cb4a90298f 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -315,6 +315,17 @@ supports HTTP, HTTPS and GnuTLS.")
#:parallel-tests? #f ;parallel tests aren't supported
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-problematic-tests
+ (lambda _
+ (substitute* "src/cadet/Makefile.in"
+ ;; The speed_reliable tests appear to be unreliable (see:
+ ;; https://bugs.gnunet.org/view.php?id=7787).
+ (("test_cadet_[0-9]+_speed_reliable\\$\\(EXEEXT)")
+ ""))
+ (substitute* "src/core/Makefile.in"
+ ;; The 'test_core_api' test fails non-deterministically (see:
+ ;; https://bugs.gnunet.org/view.php?id=7784).
+ (("test_core_api\\$\\(EXEEXT) ") ""))))
(add-before 'check 'set-env-var-for-tests
(lambda _
(setenv "LANG" "en_US.UTF-8")))